POJ-1611-The Suspects(并查集中集合里元素的个数)

POJ-1611-The Suspects

 

Description

Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy is to separate the suspects from others.
In the Not-Spreading-Your-Sickness University (NSYSU), there are many student groups. Students in the same group intercommunicate with each other frequently, and a student may join several groups. To prevent the possible transmissions of SARS, the NSYSU collects the member lists of all student groups, and makes the following rule in their standard operation procedure (SOP).
Once a member in a group is a suspect, all members in the group are suspects.
However, they find that it is not easy to identify all the suspects when a student is recognized as a suspect. Your job is to write a program which finds all the suspects.

Input

The input file contains several cases. Each test case begins with two integers n and m in a line, where n is the number of students, and m is the number of groups. You may assume that 0 < n <= 30000 and 0 <= m <= 500. Every student is numbered by a unique integer between 0 and n−1, and initially student 0 is recognized as a suspect in all the cases. This line is followed by m member lists of the groups, one line per group. Each line begins with an integer k by itself representing the number of members in the group. Following the number of members, there are k integers representing the students in this group. All the integers in a line are separated by at least one space.
A case with n = 0 and m = 0 indicates the end of the input, and need not be processed.

Output

For each case, output the number of suspects in one line.

Sample Input

100 4
2 1 2
5 10 13 11 12 14
2 0 1
2 99 2
200 2
1 5
5 1 2 3 4 5
1 0
0 0

Sample Output

4
1
1

根据题意就是并查集,把每个组员并在一个集合之中。又因为最初在所有情况下,学生0都被认为是可疑者。意思就是你这个集合里面只要含有学生0 那你这个整个集合里的学生个数就是答案。

分为两步走,第一步并查集,第二步记录并查集中集合里元素的个数。

 

AC代码

#include<iostream>
#include<algorithm>
#include<cstring>
using namespace std;
const int N=30010;
int p[N],size1[N];
int n,m;

int find(int x)//找根节点,并且路径压缩
{
	if(p[x]!=x)
	{
		p[x]=find(p[x]);
	}
	return p[x];
}

int main()
{
	while(scanf("%d %d",&n,&m),n!=0||m!=0)
	{
		memset(p,0,sizeof(p));
		for(int i=0;i<n;i++)	size1[i]=1;
		for(int i=0;i<n;i++)	p[i]=i;
		
		while(m--)
		{
			int k,j,l;
			scanf("%d %d",&k,&j);
			for(int i=0;i<k-1;i++)
			{
				scanf("%d",&l);
				if(find(j)==find(l))	continue;
				size1[find(l)]+=size1[find(j)];//记录集合中元素的个数
				p[find(j)]=find(l);
				
			}
		}
		cout<<size1[find(0)]<<endl;学生0的集合元素个数
	}
	return 0;
}

代码段中的size1[find(l)]+=size1[find(j)];意思是以该元素的根结点为数组下标来记录元素个数。

注意在记录个数之前要判断两个并查中的根结点是否相同。

 

 

评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值