分苹果 - C/C++ 语法基础

现有n个苹果,均分给5位同学,剩下的苹果交还老师。请编写程序,解决下述问题:

  • 每位同学能分得几个苹果?
  • 一共分出去多少个苹果?
  • 交还老师的苹果有几个?

输入样例:

17

输出样例:

Everyone have 3 apples.
15 apples have been taken in total.
returned 2 apples to the teacher.
#include <iostream>
#include <iomanip>
#include <math.h>
using namespace std;
int main()
{
    int n;
    cin >> n;
    int a,b,c;
    if(n%5==0)
    {
        a=n/5;
        b=n;
        c=0;
    }
    if(n%5 != 0)
    {
        a=floor(n/5);
        b=5*a;
        c=n%5;
    }
    cout << "Everyone have " << a << " apples."<<endl;
    cout << b <<" apples have been taken in total."<<endl;
    cout << "returned " << c << " apples to the teacher."<<endl;
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值