现有n个苹果,均分给5位同学,剩下的苹果交还老师。请编写程序,解决下述问题:
- 每位同学能分得几个苹果?
- 一共分出去多少个苹果?
- 交还老师的苹果有几个?
输入样例:
17
输出样例:
Everyone have 3 apples.
15 apples have been taken in total.
returned 2 apples to the teacher.
#include <iostream>
#include <iomanip>
#include <math.h>
using namespace std;
int main()
{
int n;
cin >> n;
int a,b,c;
if(n%5==0)
{
a=n/5;
b=n;
c=0;
}
if(n%5 != 0)
{
a=floor(n/5);
b=5*a;
c=n%5;
}
cout << "Everyone have " << a << " apples."<<endl;
cout << b <<" apples have been taken in total."<<endl;
cout << "returned " << c << " apples to the teacher."<<endl;
return 0;
}