「1162』Postfix Expression

Given a syntax tree (binary), you are supposed to output the corresponding postfix expression, with parentheses reflecting the precedences of the operators.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤ 20) which is the total number of nodes in the syntax tree. Then N lines follow, each gives the information of a node (the i-th line corresponds to the i-th node) in the format:

data left_child right_child

where data is a string of no more than 10 characters, left_child and right_child are the indices of this node’s left and right children, respectively. The nodes are indexed from 1 to N. The NULL link is represented by −1. The figures 1 and 2 correspond to the samples 1 and 2, respectively.

infix1.JPG
infix2.JPG
Figure 1Figure 2

Output Specification:

For each case, print in a line the postfix expression, with parentheses reflecting the precedences of the operators.There must be no space between any symbols.

Sample Input 1:

8
* 8 7
a -1 -1
* 4 1
+ 2 5
b -1 -1
d -1 -1
- -1 6
c -1 -1

Sample Output 1:

(((a)(b)+)((c)(-(d))*)*)

Sample Input 2:

8
2.35 -1 -1
* 6 1
- -1 4
% 7 8
+ 2 3
a -1 -1
str -1 -1
871 -1 -1

Sample Output 2:

(((a)(2.35)*)(-((str)(871)%))+)

Ω

给出一个运算式的语法树,输出它的后缀表达式。本质上就是考察树的后序遍历,唯一不同的地方在于,需要注意单目运算符【-】,如果说存在右子树但不存在左子树就说明是单目运算符,需要先输出节点的值,然后再输出右子树的后缀表达式。

⚠️根节点需要自己计算,初始化根节点序号为1-N之和,然后减去所有节点的子节点序号,最后剩下的就是根节点编号。


🐎

#include <iostream>
#include <vector>

using namespace std;
vector<string> value;
vector<pair<int, int>> sons;

string postfix(int i)
{
    if (i == -1) return "";
    else if (sons[i].first == -1) return "(" + value[i] + postfix(sons[i].second) + ")";
    else return "(" + postfix(sons[i].first) + postfix(sons[i].second) + value[i] + ")";
}

int main()
{
    int n, h;
    cin >> n;
    h = n * (n + 1) / 2;
    value.resize(n + 1), sons.resize(n + 1);
    for (int i = 1; i <= n; ++i)
    {
        cin >> value[i] >> sons[i].first >> sons[i].second;
        h -= max(0, sons[i].first) + max(0, sons[i].second);
    }
    cout << postfix(h);
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值