RIP综合实验

请添加题目

先解决ip,再处理路由,然后考虑策略

解题思路:
R1-R2-R3-R4-R5 运行RIPV2
R6-R7运行RIPV1
(在R4[R6]连接R6[R4]的接口做rip version 1[2] 使RIPV1与RIPV2互通)
1.使用合理IP地址规划网络,各自创建环回接口
2.R1创建环回 172.16.1.1/24 172.16.2.1/24 172.16.3.1/24
3.要求R3使用R2访问R1环回(修改R1环回通过R4进入R3的cost值)
4.加快网络收敛(按比例修改计时器),减少路由条目数量(手工汇总),增加路由传递安全性(路由认证)
5.R5创建一个环回模拟运营商,不能通告(在R4写一条静态缺省指向R5,并在R4做一对多nat)
acl 2000 :rule 5 permit source any
接口 :nat outbound 2000
6.R1 telnet R2环回实际telnet 到R7上(开启R2、R7Telnet密码为123,借用R2环回做网络地址转换,在R2与R1连接的接口做)
nat server protocol tcp global interface loopback 0 telnet inside 7.7.7.7 23
or:nat server protocol tcp global interface loopback 0 23 inside 7.7.7.7 23
7.R6-R7路由器不能学习到达R1环回路由(在R6与R4连接的接口用acl

AR1:
sys
sys R1
int g0/0/0
ip address 12.0.0.1 24
int l0
ip add 1.1.1.1 24
int g 0/0/1
ip address 14.0.0.1 24
q
int l1
ip address 172.16.1.1 24
int l2
ip address 172.16.2.1 24
int l3
ip address 172.16.3.1 24
display ip interface brief 查看ip是否配错
rip
v 2
network 12.0.0.0
network 14.0.0.0
network 1.0.0.0
network 172.16.0.0
display ip routing-table protocol rip
//减少路由条目数量,进行汇总
int g 0/0/0
rip summary address 172.16.0.0 255.255.252.0【rip summary address 后跟汇总地址】
rip g 0/0/1
rip summary address 172.16.0.0 255.255.252.0
q
display ip routing-table protocol rip
int g 0/0/0
rip authentation-mode md5 usual cipher 123456
telent 2.2.2.2

AR2:
sys
sys R2
int g0/0/0
ip address 12.0.0.2 24
int g 0/0/1
ip address 23.0.0.1 24
q
int l0
ip add 2.2.2.2 24
ping 12.0.0.1
ping 23.0.0.2
rip
v 2
network 12.0.0.0
network 23.0.0.0
network 2.0.0.0
display ip routing-table protocol rip
int g 0/0/0
rip authentation-mode md5 usual cipher 123456
display rip 1 route
ip route-static 172.16.0.0 22 n0 防治路由黑洞造成路由环路问题
ping 7.7.7.7
ping 6.6.6.6
ping 3.3.3.3
ping 2.2.2.2
ping 5.5.5.5 不可ping通,因为不能宣告
display ip routing-table protocol rip
int g 0/0/0
nat static protocol tcp global interface loopback 0 直接写接口名称来替代ip
nat static protocol tcp global interface loopback 0 inside 7.7.7.7 23
y
acl 2000
rule permit source 7.0.0.0 0
q
int g 0/0/0
rip metricin 2000 ?
rip metricin 2000 10 修改为10
q

AR3:
sys
sys R3
int g0/0/0
ip address 23.0.0.2 24
int g 0/0/1
ip address 34.0.0.1 24
q
int l0
ip add 3.3.3.3 24
ping 34.0.0.2
rip
v 2
network 23.0.0.0
network 34.0.0.0
network 3.0.0.0
display ip routing-table protocol rip
//要求R3使用R2访问R1环回
acl 2000
rule permit source 1.1.1.0 0
rule permit source 172.16.0.0 0
q
int g 0/0/1
rip meticin 2000 10

AR4:
sys
sys R4
int g0/0/0
ip address 14.0.0.2 24
int g 0/0/1
ip address 34.0.0.2 24
int g 0/0/2
ip address 45.0.0.1 24
int g 4/0/0
ip address 46.0.0.1 24
q
int l0
ip add 4.4.4.4 24
ping 14.0.0.1
ping 45.0.0.2
ping 46.0.0.2
rip
v 2
network 14.0.0.0
network 34.0.0.0
network 45.0.0.0
network 46.0.0.0
network 4.0.0.0
display ip routing-table protocol rip
acl 2000
rule permit source 12.0.0.0
q
int g 0/0/0
rip metricont
rip metricin 2000 10

AR5:
sys
sys R5
int g0/0/0
ip address 45.0.0.2 24
int l0
ip add 5.5.5.5 24
q
ping 45.0.0.1
rip
v 2
network 45.0.0.0
display ip routing-table protocol rip
rip
default-cost
default-route originate

AR6:
sys
sys R6
int g0/0/0
ip address 46.0.0.2 24
int g 0/0/1
ip address 67.0.0.1 24
q
int l0
ip add 6.6.6.6 24
display ip interface brief
ping 67.0.0.2
rip
v 1
network 46.0.0.0
network 67.0.0.0
network 6.0.0.0
display ip routing-table protocol rip
int g 0/0/0
rip version 2
//R6-R7路由器不能学习到达R1环回路由—可以直接在R6上进行过滤
acl 2000
rule deny source 172.16.0.0 0
rule deny source 1.1.1.0 0
rule permit source any
q
rip
filter-policy 2000 import
q
ping 7.7.7.7
telnet 7.7.7.7

AR7:
sys
sys R7
int g0/0/0
ip address 67.0.0.2 24
int l0
ip add 7.7.7.7 24
q
rip
v 1
network 67.0.0.0
network 7.0.0.0
display ip routing-table protocol rip
aaa
local-user lbs privilege lecel 15 password cipher 29920814
local-user lbs service-type telnet
q
user-group
user-interface vty 0 4
acl-ping
authentication-mode aaa
在这里插入图片描述

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值