POJ-3616 Milking Time(dp)

本文探讨了一个关于优化农场动物生产力的问题。贝西是一头勤奋的奶牛,农夫约翰有一系列可能重叠的挤奶时间区间,每个区间有不同的效率。每完成一次挤奶后,贝西需要休息特定小时数。任务是确定在给定时间内,如何安排挤奶以最大化牛奶产量。通过动态规划解决这个问题,代码展示了如何找到最佳挤奶顺序以达到最大产出。
摘要由CSDN通过智能技术生成

Bessie is such a hard-working cow. In fact, she is so focused on maximizing her productivity that she decides to schedule her next N (1 ≤ N ≤ 1,000,000) hours (conveniently labeled 0…N-1) so that she produces as much milk as possible.

Farmer John has a list of M (1 ≤ M ≤ 1,000) possibly overlapping intervals in which he is available for milking. Each interval i has a starting hour (0 ≤ starting_houri ≤ N), an ending hour (starting_houri < ending_houri ≤ N), and a corresponding efficiency (1 ≤ efficiencyi ≤ 1,000,000) which indicates how many gallons of milk that he can get out of Bessie in that interval. Farmer John starts and stops milking at the beginning of the starting hour and ending hour, respectively. When being milked, Bessie must be milked through an entire interval.

Even Bessie has her limitations, though. After being milked during any interval, she must rest R (1 ≤ R ≤ N) hours before she can start milking again. Given Farmer Johns list of intervals, determine the maximum amount of milk that Bessie can produce in the N hours.

Input

  • Line 1: Three space-separated integers: N, M, and R
  • Lines 2…M+1: Line i+1 describes FJ’s ith milking interval withthree space-separated integers: starting_houri , ending_houri , and efficiencyi

Output

  • Line 1: The maximum number of gallons of milk that Bessie can product in the N hours
  • 翻译

  • 贝西在时间内可以产奶
  • 农夫约翰有一些时间间隔(1≤ M≤ 1000),在时间间隔内他可以帮助贝西产奶。每个间隔都有一个起始小时(0≤ 开始时间≤ N) ,一个结束的小时(开始时间<结束时间≤ N)
  • 农夫约翰分别在开始时间和结束时间开始和停止挤奶。在挤奶时,贝西必须在整个时间间隔内产奶。贝西也有她的局限性。在产奶结束后,她必须休息R(1≤ R≤ N) 几小时后她才能开始挤奶。
  • 求贝西在N小时内可以生产的最大牛奶量。

Sample Input

12 4 2
1 2 8
10 12 19
3 6 24
7 10 31

Sample Output

43

代码

#include "stdio.h"
#include "algorithm"
#include "string.h"
using namespace std;
int dp[1009];
struct ppp
{
	int a,b,c;
}p[1009],h;
int qqq(ppp x,ppp y)
{
	if(x.a==y.a)
	return x.b<y.b;
	return x.a<y.a;
}
int main()
{
	int i,m,n,j,k,l=0,s;
	scanf("%d%d%d",&s,&n,&k);
	for(i=0;i<n;i++)
	{
		scanf("%d %d %d",&p[i].a,&p[i].b,&p[i].c);
		p[i].b+=k;
	}
	sort(p,p+n,qqq);
	for(i=0;i<n;i++)
	{//因为用时间段来写dp数组很麻烦,所以我们就用它的排列顺序来写dp数组
		dp[i]=p[i].c;//我们是以它的排列顺序写的dp数组,和平时有些不一样 
		for(j=0;j<i;j++)
		{
			if(p[j].b<=p[i].a)
			{
				dp[i]=max(dp[i],dp[j]+p[i].c);
				l=max(l,dp[i]);
			}
		}
	}
	printf("%d\n",l);
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值