PAT 1002 A+B for Polynomials(合并多项式)

This time, you are supposed to find A+B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:

KN1aN1N2aN2 ... NKaNK

where K is the number of nonzero terms in the polynomial, Ni and aNi (i=1,2,⋯,K) are the exponents and coefficients, respectively. It is given that 1≤K≤10,0≤NK<⋯<N2<N1≤1000.

Output Specification:

For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must

be NO extra space at the end of each line. Please be accurate to 1

decimal place.

Sample Input:

2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output:

3 2 1.5 1 2.9 0 3.2

合并多项式,给出每行的第一个数代表该多项式有几项,然后每两个数字分别代表第几项以及它对应的系数。左后将给出的两个多项式相加。

#include <iostream>
using namespace std;
int main(){
    int n,i,max=0,k,count=0;
    double s,a[1001]={0};
    for (int j=0;j<2;j++){
        scanf("%d",&n);
        for (i=1;i<=n;i++){
            scanf("%d%lf",&k,&s);
            if (a[k]==0) count++;
            a[k]+=s;
            if (a[k]==0) count--;
            if (k>max) max=k;
        }
    }
    printf("%d",count);
    while (max>=0){
        if (a[max]!=0){
            printf(" %d %.1f",max,a[max]);
        }
        max--;
    }
    return 0;
}

结果:

  • 2
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值