【PAT(甲级)】1001 A+B Format

Calculate a+b and output the sum in standard format -- that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input Specification:

Each input file contains one test case. Each case contains a pair of integers a and b where −106≤a,b≤106. The numbers are separated by a space.

Output Specification:

For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Input:

-1000000 9


Sample Output:

-999,991

题目思路:

难点就在于逗号的插入(从右往左!从右往左!从右往左!)。按照题目要求,每三个数字都要插入一个逗号,末尾(开头)不需要插入逗号。很自然的想到将数字类型转换成字符串,然后每三个数字分一组插入逗号即可。

题目中给的输出例子不是很好,例如-9999999输出应该是-9,999,999这样应该就可以理解自己的部分错误在哪里啦。 

代码:

#include<bits/stdc++.h>
#include<stdio.h>
using namespace std;
void to_print(string a[],int num){
	for(int i=num;i>=0;i--){
		cout<<a[i];
	}
}
int main(){
    int a,b;
    cin>>a>>b;
    string c = to_string(a+b);
    int num,pos;
    num=0;
    pos=c.size()-1;
    string d[1000]={};
    if(c[0]=='-'){
    	if(pos<4) cout<<c;
    	else{
    		while(pos>=0){
    			if(pos-3>0){
    				d[num]=',';
					for(int i=pos-2;i<=pos;i++){
    					d[num]+=c[i];
					}
					num++;
					pos-=3;
				}
    			else{
    				for(int i=0;i<=pos;i++){
    					d[num]+=c[i];
					}	
					break;
				}
			}
			to_print(d,num);
		}
	}
	else{
		if(pos<3) cout<<c;
    	else{
    		while(pos>=0){
    			if(pos-3>=0){
    				d[num]=',';
					for(int i=pos-2;i<=pos;i++){
    					d[num]+=c[i];
					}
					num++;
					pos-=3;
				}
    			else{
    				for(int i=0;i<=pos;i++){
    					d[num]+=c[i];
					}	
					break;
				}
			}
			to_print(d,num);
		}
	}
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值