【PAT(甲级)】1022 Digital Library

A Digital Library contains millions of books, stored according to their titles, authors, key words of their abstracts, publishers, and published years. Each book is assigned an unique 7-digit number as its ID. Given any query from a reader, you are supposed to output the resulting books, sorted in increasing order of their ID's.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤104) which is the total number of books. Then N blocks follow, each contains the information of a book in 6 lines:

  • Line #1: the 7-digit ID number;
  • Line #2: the book title -- a string of no more than 80 characters;
  • Line #3: the author -- a string of no more than 80 characters;
  • Line #4: the key words -- each word is a string of no more than 10 characters without any white space, and the keywords are separated by exactly one space;
  • Line #5: the publisher -- a string of no more than 80 characters;
  • Line #6: the published year -- a 4-digit number which is in the range [1000, 3000].

It is assumed that each book belongs to one author only, and contains no more than 5 key words; there are no more than 1000 distinct key words in total; and there are no more than 1000 distinct publishers.

After the book information, there is a line containing a positive integer M (≤1000) which is the number of user's search queries. Then M lines follow, each in one of the formats shown below:

  • 1: a book title
  • 2: name of an author
  • 3: a key word
  • 4: name of a publisher
  • 5: a 4-digit number representing the year

Output Specification:

For each query, first print the original query in a line, then output the resulting book ID's in increasing order, each occupying a line. If no book is found, print Not Found instead.

Sample Input:

3
1111111
The Testing Book
Yue Chen
test code debug sort keywords
ZUCS Print
2011
3333333
Another Testing Book
Yue Chen
test code sort keywords
ZUCS Print2
2012
2222222
The Testing Book
CYLL
keywords debug book
ZUCS Print2
2011
6
1: The Testing Book
2: Yue Chen
3: keywords
4: ZUCS Print
5: 2011
3: blablabla

Sample Output:

1: The Testing Book
1111111
2222222
2: Yue Chen
1111111
3333333
3: keywords
1111111
2222222
3333333
4: ZUCS Print
1111111
5: 2011
1111111
2222222
3: blablabla
Not Found

解题思路:

由于题目要求是当输入一个搜索词的时候,返回这个搜索词的ID值,不止一个的时候按照ID从小到大输出。如果构建一个struct来存储书的信息然后再来寻找就会很麻烦,所以根据string搜索ID,很自然地就能想到用map函数。

然后map<>里面,前半个参数很显然是string类型,后半个要能存储多个ID且要按照升序排序而且还不能有重复,那么没错了肯定是set函数。所以存储的类型就是map<string,set<string>>啦(set<>默认是升序排序且没有重复元素)。

易错点:

1.在用getline()读取一行元素之前,如果你是用cin,scanf等读取N,M的记得用getchar()来消除换行符,不然读入顺序就会出错。

2.在处理the key words时每个空格前后的字符串都是可以对应ID的所以需要一个循环来解决存储问。这部分代码如下:

while(cin>>key){
			book[key].insert(id);
			char a = getchar();
			if(a=='\n') break;
		}

代码:

#include<bits/stdc++.h>
using namespace std;
map<string,set<string>> book;//存储书本信息 
int main(){
	int N,M;
	cin>>N;getchar();//要把换行符号给去掉 
	string id,title,author,key,pub,year;
	for(int i=0;i<N;i++){
		getline(cin,id);
		getline(cin,title);
		book[title].insert(id);
		getline(cin,author);
		book[author].insert(id);
		while(cin>>key){
			book[key].insert(id);
			char a = getchar();
			if(a=='\n') break;
		}
		getline(cin,pub);
		book[pub].insert(id);
		getline(cin,year);
		book[year].insert(id);
	}
	cin>>M;getchar();//一样去掉换行符号 
	while(M--){
		int s;string nam;
		scanf("%d: ",&s);
		getline(cin,nam);
		cout<<s<<": "<<nam<<endl;
		if(!book[nam].size()) cout<<"Not Found"<<endl;
		else{
			for(auto i=book[nam].begin();i!=book[nam].end();i++){
				cout<<*i<<endl;
			}
		}
	}
	return 0;
}

  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值