1022 Digital Library (30分)

A Digital Library contains millions of books, stored according to their titles, authors, key words of their abstracts, publishers, and published years. Each book is assigned an unique 7-digit number as its ID. Given any query from a reader, you are supposed to output the resulting books, sorted in increasing order of their ID’s.
Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤10​4​​) which is the total number of books. Then N blocks follow, each contains the information of a book in 6 lines:

Line #1: the 7-digit ID number;
Line #2: the book title -- a string of no more than 80 characters;
Line #3: the author -- a string of no more than 80 characters;
Line #4: the key words -- each word is a string of no more than 10 characters without any white space, and the keywords are separated by exactly one space;
Line #5: the publisher -- a string of no more than 80 characters;
Line #6: the published year -- a 4-digit number which is in the range [1000, 3000].

It is assumed that each book belongs to one author only, and contains no more than 5 key words; there are no more than 1000 distinct key words in total; and there are no more than 1000 distinct publishers.

After the book information, there is a line containing a positive integer M (≤1000) which is the number of user’s search queries. Then M lines follow, each in one of the formats shown below:

1: a book title
2: name of an author
3: a key word
4: name of a publisher
5: a 4-digit number representing the year

Output Specification:

For each query, first print the original query in a line, then output the resulting book ID’s in increasing order, each occupying a line. If no book is found, print Not Found instead.
Sample Input:

3
1111111
The Testing Book
Yue Chen
test code debug sort keywords
ZUCS Print
2011
3333333
Another Testing Book
Yue Chen
test code sort keywords
ZUCS Print2
2012
2222222
The Testing Book
CYLL
keywords debug book
ZUCS Print2
2011
6
1: The Testing Book
2: Yue Chen
3: keywords
4: ZUCS Print
5: 2011
3: blablabla

Sample Output:

1: The Testing Book
1111111
2222222
2: Yue Chen
1111111
3333333
3: keywords
1111111
2222222
3333333
4: ZUCS Print
1111111
5: 2011
1111111
2222222
3: blablabla
Not Found

题意:题目本身意思是给出N本书,输入每本书的编号,书名,作者,关键词,出版社,出版年,之后给出书的书名,作者,关键词,出版社,出版年要求分别输出编号

思路:由于一个书名,作者,关键词,出版社,出版年可以对应多个书号,而且书号是唯一的,输出格式要求升序,所以此处需要利用map<string,set>mp来进行匹配,这个的意思就是由一个书名,作者,关键词,出版社,出版年来对应输入多个编号,例如mp[Yue Chen]={1111,222,333};这种情况;由此就可以 一 一得出了;这里还需要注意的一点就是除了关键词以外的输入都是整块输入,而关键词有多个关键词,处理的时候需要使用getchar()来去掉中间的空格;其余的用getline()输入即可

AC

#include<stdio.h>
#include<iostream>
#include<string>
#include<map>
#include<set>
using namespace std;
map<string,set<int> > mptitle,mpauthor,mpkey,mppub,mpyear;
void print(map<string,set<int> >&mp,string &str){
	if(mp.find(str)==mp.end())printf("Not Found\n");//找不到的判断
	else{//这里的迭代器是set的
		for(set<int>::iterator it=mp[str].begin();it!=mp[str].end();it++){
			printf("%07d\n",*it);
		}
	}
}
int main(){
	int n,q,id;
	string title,author,key,pub,year;
	scanf("%d",&n);
	for(int i=0;i<n;i++){
		scanf("%d",&id);
        char c=getchar();//去除输入id后的换行符
		getline(cin,title);
		mptitle[title].insert(id);
		getline(cin,author);
		mpauthor[author].insert(id);
		while(1){
			cin>>key;
			mpkey[key].insert(id);
			char c=getchar();//去除空格·
			if(c=='\n')break;
		}
		getline(cin,pub);
		mppub[pub].insert(id);
		getline(cin,year);
		mpyear[year].insert(id);
	}
	scanf("%d",&q);
	int type;
	string name;
	for(int i=0;i<q;i++){
		scanf("%d: ",&type);
		getline(cin,name);
		cout<<type<<": "<<name<<endl;
		if(type==1)print(mptitle,name);
		else if(type==2)print(mpauthor,name);
		else if(type==3)print(mpkey,name);
		else if(type==4)print(mppub,name);
		else print(mpyear,name);	
	}	
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值