1001 A+B Format (20 分)

Calculate a+b and output the sum in standard format -- that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input Specification:

Each input file contains one test case. Each case contains a pair of integers a and b where −106≤a,b≤106. The numbers are separated by a space.

Output Specification:

For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Input:

-1000000 9

结尾无空行

Sample Output:

-999,991

结尾无空行

初次写的代码如下,但运行方向有几个测试点总是错的,百思不得其解。

#include<iostream>
#include<string>
using namespace std;
int main() {
	int a, b, c;
	cin >> a >> b;
	c = a + b;
	string q = to_string(c);     //计算字符串长度
	int len = q.length();
	if (q[0] == '-') {          //当和为负数时执行
		cout << q[0];
		for (int i = 1; i < len; i++) {
			cout << q[i];
			if (i  % 3 == 0 && i != len - 1)cout << ",";
		}
	}
	else {
		for (int i = 0; i < len; i++) {   //当和为正数时执行
			cout << q[i];
			if ((i + 1) % 3 == 0 && i != len - 1)cout << ",";
		}
	}
return 0;
}

后面修改后的代码如下:


#include<iostream>
#include<string>
#include<cmath>
using namespace std;
int main() {
	int a, b, c;
	cin >> a >> b;

	string q = to_string(a+b);
	int len = q.length();
	for (int i = 0; i < len; i++) {
		cout << q[i];
		if (q[i] == '-')continue;
		if ((i + 1) % 3 == len % 3 && i != len - 1)cout << ",";
	}
	return 0;
}

用Java用的如下:

import java.util.Scanner;
public class Test{
    public static void main(String[] args){
        Scanner in=new Scanner(System.in);
        int a=in.nextInt();
        int b=in.nextInt();
        int sum=a+b;
         if(sum<0){
            System.out.print("-");
            sum=0-sum;
        }
        String s=String.valueOf(sum);
        StringBuilder s2=new StringBuilder(s);
        int len=s.length();
       if(len<=3){
           System.out.print(s);

       }
       else if(len<=6){
           s2.insert(len-3,",");
           System.out.print(s2.toString());
       }
       else {
           s2.insert(len-3,",");
           s2.insert(len-6,",");
           System.out.print(s2.toString());
       }
        
    }
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值