Hero(题解)

这篇博客探讨了一个在 DotA 游戏中面对强大敌人和弱小队友时的策略问题。核心是英雄具有无限生命值但攻击力极低,在回合制战斗中如何以最小的生命值损失消灭所有敌人。博主通过分析游戏机制,提出将敌方英雄按特定排序规则(总伤害输出和生命值的组合)进行排序,并采用贪心算法来选择攻击目标。代码实现中使用了快速排序并给出了详细步骤,最终展示了如何计算最小生命值损失的方法。
摘要由CSDN通过智能技术生成

When playing DotA with god-like rivals and pig-like team members, you have to face an embarrassing situation: All your teammates are killed, and you have to fight 1vN.

There are two key attributes for the heroes in the game, health point (HP) and damage per shot (DPS). Your hero has almost infinite HP, but only 1 DPS.

To simplify the problem, we assume the game is turn-based, but not real-time. In each round, you can choose one enemy hero to attack, and his HP will decrease by 1. While at the same time, all the lived enemy heroes will attack you, and your HP will decrease by the sum of their DPS. If one hero's HP fall equal to (or below) zero, he will die after this round, and cannot attack you in the following rounds.

Although your hero is undefeated, you want to choose best strategy to kill all the enemy heroes with minimum HP loss.

Input

The first line of each test case contains the number of enemy heroes N (1 <= N <= 20). Then N lines followed, each contains two integers DPSi and HPi, which are the DPS and HP for each hero. (1 <= DPSi, HPi <= 1000)

Output

Output one line for each test, indicates the minimum HP loss.

Sample Input

1
10 2
2
100 1
1 100

Sample Output

20
201

思路:

看着很复杂,但实际就是一个贪心题目,可以用快速排序先排序,要注意的是排序规则,不能片面的看血多血少,要统计伤害如何最高,伤害如何最低!

代码:

#include<cstdio>
#include<algorithm>
#include<iostream>
using namespace std;
struct node{
	int hp;
	int dps;
}enemy[10010];

bool cmp(node a,node b){//排序规则特殊!
	return  (((a.dps+b.dps)*a.hp+b.dps*b.hp) < ((a.dps+b.dps)*b.hp+a.hp*a.dps));
}

//int hits(int hi,int att){
//	for(i=0;i<n;i++){
//		for(j=0;j<enemy[i].hp;j++){
//			attack += hit;
//		}
//		hit -= enemy[i].dps;//一开始伤害是满的,后面伤害慢慢的变少
//	}
//}
int main()
{
	int attack=0,i,j,n,hit=0;
	while(scanf("%d",&n)!=EOF){
		for(i=0;i<n;i++)
		{
			scanf("%d%d",&enemy[i].hp,&enemy[i].dps);
		 } 
		sort(enemy,enemy+n,cmp);
		for(i=0;i<n;i++){
			hit += enemy[i].dps;
		}
		for(i=0;i<n;i++){
			for(j=0;j<enemy[i].hp;j++){
				attack += hit;
			}
			hit -= enemy[i].dps;
		}
		printf("%d\n",attack);
		attack =0;
	}
	return 0;
	
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值