hdu4310简单贪心Hero

Hero

Problem Description
When playing DotA with god-like rivals and pig-like team members, you have to face an embarrassing situation: All your teammates are killed, and you have to fight 1vN.

There are two key attributes for the heroes in the game, health point (HP) and damage per shot (DPS). Your hero has almost infinite HP, but only 1 DPS.

To simplify the problem, we assume the game is turn-based, but not real-time. In each round, you can choose one enemy hero to attack, and his HP will decrease by 1. While at the same time, all the lived enemy heroes will attack you, and your HP will decrease by the sum of their DPS. If one hero’s HP fall equal to (or below) zero, he will die after this round, and cannot attack you in the following rounds.

Although your hero is undefeated, you want to choose best strategy to kill all the enemy heroes with minimum HP loss.

Input
The first line of each test case contains the number of enemy heroes N (1 <= N <= 20). Then N lines followed, each contains two integers DPSi and HPi, which are the DPS and HP for each hero. (1 <= DPSi, HPi <= 1000)

Output
Output one line for each test, indicates the minimum HP loss.

Sample Input
1
10 2
2
100 1
1 100

Sample Output
20
201
简单分析一下,因为题目也不是很难,我们要让自己的生命值扣得最少,因此要让我们的每一次攻击收益达到最高,一次攻击的收益是:攻击力/生命值,然后按照这个sort一下然后用个循环计算一下hp损失就完事了,注意这里他没有说dps和hp的类型,在这里是攻击力或生命值是可以为浮点数的,所以要把dps和hp设置为double就可以了。(这个刚开始没有注意浪费了一会时间)
直接交代码了(c++):

#include<iostream>
#include<string>
#include<string.h>
#include<algorithm>
using namespace std;

struct enm{
    double dps;
    double hp;
};
bool com(struct enm x,struct enm y){
    return x.dps/x.hp>y.dps/y.hp;
}
struct enm a[30];
int main()
{
    int n;
    while(cin>>n){
        memset(a,0,sizeof(a));
        for(int i=0;i<n;i++){
            cin>>a[i].dps>>a[i].hp;
        }
        double sum=0;
        sort(a,a+n,com);
        for(int k=0;k<n;k++){
            while(a[k].hp!=0){
                for(int j=0;j<n;j++){
                    if(a[j].hp!=0)
                    sum+=a[j].dps;
                }
            a[k].hp--;
        }
    }
        cout<<sum<<endl;
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
以下是hdu4310的Java解法: ```java import java.util.*; import java.io.*; public class Main { static int MAXN = 100010; static int MAXM = 200010; static int INF = 0x3f3f3f3f; static int n, m, s, t, cnt; static int[] head = new int[MAXN]; static int[] dis = new int[MAXN]; static boolean[] vis = new boolean[MAXN]; static int[] pre = new int[MAXN]; static int[] cur = new int[MAXN]; static class Edge { int to, next, cap, flow, cost; public Edge(int to, int next, int cap, int flow, int cost) { this.to = to; this.next = next; this.cap = cap; this.flow = flow; this.cost = cost; } } static Edge[] edge = new Edge[MAXM]; static void addEdge(int u, int v, int cap, int flow, int cost) { edge[cnt] = new Edge(v, head[u], cap, flow, cost); head[u] = cnt++; edge[cnt] = new Edge(u, head[v], 0, 0, -cost); head[v] = cnt++; } static boolean spfa() { Arrays.fill(dis, INF); Arrays.fill(vis, false); Queue<Integer> q = new LinkedList<>(); q.offer(s); dis[s] = 0; vis[s] = true; while (!q.isEmpty()) { int u = q.poll(); vis[u] = false; for (int i = head[u]; i != -1; i = edge[i].next) { int v = edge[i].to; if (edge[i].cap > edge[i].flow && dis[v] > dis[u] + edge[i].cost) { dis[v] = dis[u] + edge[i].cost; pre[v] = u; cur[v] = i; if (!vis[v]) { vis[v] = true; q.offer(v); } } } } return dis[t] != INF; } static int[] MCMF(int s, int t) { int flow = 0, cost = 0; while (spfa()) { int f = INF; for (int u = t; u != s; u = pre[u]) { f = Math.min(f, edge[cur[u]].cap - edge[cur[u]].flow); } for (int u = t; u != s; u = pre[u]) { edge[cur[u]].flow += f; edge[cur[u] ^ 1].flow -= f; cost += edge[cur[u]].cost * f; } flow += f; } return new int[]{flow, cost}; } public static void main(String[] args) { Scanner in = new Scanner(new BufferedReader(new InputStreamReader(System.in))); int T = in.nextInt(); for (int cas = 1; cas <= T; cas++) { n = in.nextInt(); m = in.nextInt(); s = 0; t = n + m + 1; cnt = 0; Arrays.fill(head, -1); for (int i = 1; i <= n; i++) { int c = in.nextInt(); addEdge(s, i, c, 0, 0); } for (int i = 1; i <= m; i++) { int c = in.nextInt(); addEdge(i + n, t, c, 0, 0); } for (int i = 1; i <= n; i++) { for (int j = 1; j <= m; j++) { int c = in.nextInt(); addEdge(i, j + n, INF, 0, c); } } int[] ans = MCMF(s, t); System.out.printf("Case #%d: %d\n", cas, ans[1]); } } } ```

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值