(2)Q - 贪心

When playing DotA with god-like rivals and pig-like team members, you have to face an embarrassing situation: All your teammates are killed, and you have to fight 1vN.

There are two key attributes for the heroes in the game, health point (HP) and damage per shot (DPS). Your hero has almost infinite HP, but only 1 DPS.

To simplify the problem, we assume the game is turn-based, but not real-time. In each round, you can choose one enemy hero to attack, and his HP will decrease by 1. While at the same time, all the lived enemy heroes will attack you, and your HP will decrease by the sum of their DPS. If one hero's HP fall equal to (or below) zero, he will die after this round, and cannot attack you in the following rounds.

Although your hero is undefeated, you want to choose best strategy to kill all the enemy heroes with minimum HP loss.
Input The first line of each test case contains the number of enemy heroes N (1 <= N <= 20). Then N lines followed, each contains two integers DPSi and HPi, which are the DPS and HP for each hero. (1 <= DPSi, HPi <= 1000) Output Output one line for each test, indicates the minimum HP loss. Sample Input
1
10 2
2
100 1
1 100
Sample Output
 

20
201
题意:我们的hero,攻击每秒为一,有n组敌人同时攻击,他们各自有各自的血量和攻击,求我们的hero最小损失的血量,输入n表示有n个敌人,再输入DPSi和HPi(题目没有说清谁先输入),然而是先输入HP。

    思路:我们的英雄应该优先攻击那些DPS/HP大的敌人,因为比值越大每秒损失的血量就越大,因为是所有敌人,同时攻击,所以要算出当前总攻击。
#include<iostream>
#include<cstdio>
#include<algorithm>
using namespace std;
struct node
{
 double DPS;
 double HP;
}m[25];
bool cmp(node x,node y)
{
 
  return x.DPS/x.HP>y.DPS/y.HP; //优先攻击比值大的
}
int main()
{
  int n,i;
  double sum,num;
  while(cin>>n)
  {
   sum=0,num=0;
   for(i=0;i<n;i++)
   {
    cin>>m[i].HP>>m[i].DPS;
    num+=m[i].DPS; //总攻击  
   }
   sort(m,m+n,cmp);
   for(i=0;i<n;i++)
   {
    sum+=m[i].HP*num;//当前受到的伤害
    num-=m[i].DPS; //更新当前攻击
   }
   cout<<sum<<endl;
   
  }
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值