PAT 1020 Tree Traversals

文章描述了如何根据后序遍历和中序遍历序列重建一棵二叉树,并使用层次遍历算法输出其节点顺序。给出一个示例输入和输出,展示了如何通过递归和队列实现这个过程。
摘要由CSDN通过智能技术生成

Suppose that all the keys in a binary tree are distinct positive integers. Given the postorder and inorder traversal sequences, you are supposed to output the level order traversal sequence of the corresponding binary tree.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤30), the total number of nodes in the binary tree. The second line gives the postorder sequence and the third line gives the inorder sequence. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the level order traversal sequence of the corresponding binary tree. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:

7
2 3 1 5 7 6 4
1 2 3 4 5 6 7

Sample Output:

4 1 6 3 5 7 2

Code:

#include<iostream>
#include<algorithm>
#include<unordered_map>
using namespace std;
const int N=40;
int n;
int postorder[N],inorder[N];
unordered_map<int,int>l,r,pos;
int q[N];
int build(int il,int ir,int pl,int pr)
{
    int root=postorder[pr];
    int k=pos[root];
    if(il<k)
        l[root]=build(il,k-1,pl,pl+(k-1-il));
    if(ir>k)
        r[root]=build(k+1,ir,pl+(k-1-il)+1,pr-1);
    return root;
}
void bfs(int root)
{
    int hh=0,tt=-1;
    q[++tt]=root;
    while(hh<=tt)
    {
        int t=q[hh++];
        if(l.count(t))
            q[++tt]=l[t];
        if(r.count(t))
            q[++tt]=r[t];
    }
    cout<<q[0];
    for(int i=1;i<n;i++)
        cout<<' '<<q[i];
    cout<<endl;
}
int main()
{
    cin>>n;
    for(int i=0;i<n;i++)
        cin>>postorder[i];
    for(int i=0;i<n;i++)
    {
        cin>>inorder[i];
        pos[inorder[i]]=i;
    }
    int root=build(0,n-1,0,n-1);
    bfs(root);
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值