For any 4-digit integer except the ones with all the digits being the same, if we sort the digits in non-increasing order first, and then in non-decreasing order, a new number can be obtained by taking the second number from the first one. Repeat in this manner we will soon end up at the number 6174
-- the black hole of 4-digit numbers. This number is named Kaprekar Constant.
For example, start from 6767
, we'll get:
7766 - 6677 = 1089
9810 - 0189 = 9621
9621 - 1269 = 8352
8532 - 2358 = 6174
7641 - 1467 = 6174
... ...
Given any 4-digit number, you are supposed to illustrate the way it gets into the black hole.
Input Specification:
Each input file contains one test case which gives a positive integer N in the range (0,104).
Output Specification:
If all the 4 digits of N are the same, print in one line the equation N - N = 0000
. Else print each step of calculation in a line until 6174
comes out as the difference. All the numbers must be printed as 4-digit numbers.
Sample Input 1:
6767
Sample Output 1:
7766 - 6677 = 1089
9810 - 0189 = 9621
9621 - 1269 = 8352
8532 - 2358 = 6174
Sample Input 2:
2222
Sample Output 2:
2222 - 2222 = 0000
Code:
#include<bits/stdc++.h>
using namespace std;
int n;
bool flag=true;
vector<int>s;
void calc(int x){
s.clear();
while(x){
s.push_back(x%10);
x/=10;
}
while(s.size()<4)
s.push_back(0);
}
int main(){
cin>>n;
calc(n);
for(int i=1;i<s.size();i++){
if(s[i]!=s[i-1]) {
flag=false;
break;
}
}
if(flag){
for(int i=s.size()-1;i>=0;i--)
cout<<s[i];
cout<<" - ";
for(int i=s.size()-1;i>=0;i--)
cout<<s[i];
cout<<" = 0000"<<endl;
}else{
bool st=true;
while(n!=6174||st){
int sum1=0,sum2=0;
calc(n);
sort(s.begin(),s.end());
vector<int>h;
h.clear();
h=s;
for(int i=s.size()-1;i>=0;i--)
sum1=sum1*10+s[i];
reverse(h.begin(),h.end());
for(int i=h.size()-1;i>=0;i--)
sum2=sum2*10+h[i];
// cout<<sum1<<" "<<sum2<<endl;
if(sum1>sum2){
for(int i=s.size()-1;i>=0;i--)
cout<<s[i];
cout<<" - ";
for(int i=h.size()-1;i>=0;i--)
cout<<h[i];
cout<<" = ";
calc(sum1-sum2);
for(int i=s.size()-1;i>=0;i--)
cout<<s[i];
cout<<endl;
}else{
for(int i=h.size()-1;i>=0;i--)
cout<<h[i];
cout<<" - ";
for(int i=s.size()-1;i>=0;i--)
cout<<s[i];
cout<<" = ";
calc(sum2-sum1);
for(int i=s.size()-1;i>=0;i--)
cout<<s[i];
cout<<endl;
}
n=abs(sum1-sum2);
st=false;
}
}
}