1076 Forwards on Weibo

Weibo is known as the Chinese version of Twitter. One user on Weibo may have many followers, and may follow many other users as well. Hence a social network is formed with followers relations. When a user makes a post on Weibo, all his/her followers can view and forward his/her post, which can then be forwarded again by their followers. Now given a social network, you are supposed to calculate the maximum potential amount of forwards for any specific user, assuming that only L levels of indirect followers are counted.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers: N (≤1000), the number of users; and L (≤6), the number of levels of indirect followers that are counted. Hence it is assumed that all the users are numbered from 1 to N. Then N lines follow, each in the format:

M[i] user_list[i]

where M[i] (≤100) is the total number of people that user[i] follows; and user_list[i] is a list of the M[i] users that followed by user[i]. It is guaranteed that no one can follow oneself. All the numbers are separated by a space.

Then finally a positive K is given, followed by K UserID's for query.

Output Specification:

For each UserID, you are supposed to print in one line the maximum potential amount of forwards this user can trigger, assuming that everyone who can view the initial post will forward it once, and that only L levels of indirect followers are counted.

Sample Input:

7 3
3 2 3 4
0
2 5 6
2 3 1
2 3 4
1 4
1 5
2 2 6

Sample Output:

4
5

题目大意:转发微信,粉丝转发,粉丝的粉丝也可以转发,到达一定传递层数粉丝的粉丝就不会转发了,问对一个人来说最多传递几个。

思路:可以将粉丝之间的关系看成城市间的距离,找到每个城市之间的最小距离,然后这个最小距离小于对应的层数就可以统计出对应的人数了,即用floyd算法,唯一需要注意的是在输入的格式是他关注的人,而不是关注他的人。

#include <bits/stdc++.h>
using namespace std;
#define inf 9999999
int main(){
    int n,m;
    scanf("%d%d",&n,&m);
    int i;
    int a[n+1][n+1];
    fill(a[0],a[0]+(n+1)*(n+1),inf);//初始化操做
    for(i=1;i<=n;i++)a[i][i]=0;
    int num,j;
    for(i=1;i<=n;i++){
        scanf("%d",&num);
        for(j=0;j<num;j++){//规定a[i][j]为i对j节点的贡献度。
            int val;
            scanf("%d",&val);
            a[i][val]=1;
        }
    }
    int k;
    for(i=1;i<=n;i++){//找到各个介点的最近关系
        for(j=1;j<=n;j++){
            for(k=1;k<=n;k++){
                if(a[j][k]>a[j][i]+a[i][k]){
                    a[j][k]=a[j][i]+a[i][k];
                }
            }
        }
    }
    int cha;
    scanf("%d",&cha);
    int nums[n+1];
    memset(nums,0,sizeof(nums));
    for(i=1;i<=n;i++){//枚举每个节点对该点贡献度,即他关注的对象并转发的数量
        for(j=1;j<=n;j++){
            if(j!=i&&a[i][j]<=m)nums[j]++;
        }   
    }
    for(i=0;i<cha;i++){
        scanf("%d",&num);
        printf("%d\n",nums[num]);
    }
    system("pause");
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值