习题8-7 字符串排序 (20 分)-PTA浙大版《C语言程序设计(第4版)》

本题要求编写程序,读入5个字符串,按由小到大的顺序输出。

输入格式:

输入为由空格分隔的5个非空字符串,每个字符串不包括空格、制表符、换行符等空白字符,长度小于80。

输出格式:

按照以下格式输出排序后的结果:

After sorted:
每行一个字符串

输入样例:

red yellow blue black white

结尾无空行

输出样例:

After sorted:
black
blue
red
white
yellow

结尾无空行

#include<string.h>
#include<stdio.h>
#include<stdlib.h>
struct ch {
	char ch[80];
};
int cmp_char(const void* e1, const void* e2)
{
	return strcmp(((struct ch*)e1)->ch, ((struct ch*)e2)->ch);
}
int main()
{	
	struct ch arr[5];
	int k = 0;
	for (k = 0; k < 5; k++)
	{
		scanf("%s", arr[k].ch);
	}
	qsort(arr, 5, sizeof(arr[0]), cmp_char);
	int i = 0;
	printf("After sorted:\n");
	for (i = 0; i < 5; i++)
	{
		printf("%s", arr[i].ch);
		if (i != 4)
		{
			printf("\n");
		}
	}
	return 0;
}

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值