读入 n(>0)名学生的姓名、学号、成绩,分别输出成绩最高和成绩最低学生的姓名和学号。
输入格式:
每个测试输入包含 1 个测试用例,格式为
第 1 行:正整数 n
第 2 行:第 1 个学生的姓名 学号 成绩
第 3 行:第 2 个学生的姓名 学号 成绩
... ... ...
第 n+1 行:第 n 个学生的姓名 学号 成绩
其中姓名
和学号
均为不超过 10 个字符的字符串,成绩为 0 到 100 之间的一个整数,这里保证在一组测试用例中没有两个学生的成绩是相同的。
输出格式:
对每个测试用例输出 2 行,第 1 行是成绩最高学生的姓名和学号,第 2 行是成绩最低学生的姓名和学号,字符串间有 1 空格。
输入样例:
3
Joe Math990112 89
Mike CS991301 100
Mary EE990830 95
结尾无空行
输出样例:
Mike CS991301
Joe Math990112
结尾无空行
思路:
掌握好sort函数的使用方法就行。具体可以自己去cplusplus网站看看
#include<iostream>
#include<vector>
#include<algorithm>
#include<string>
using namespace std;
struct Student
{
string name;
string id;
int score;
};
bool cmp(const Student& i, const Student& j)
{
return i.score > j.score;
}
int main()
{
int n = 0;
cin >> n;
vector <Student> arr;
arr.resize(n);
for (int i = 0; i < n; i++)
cin >> arr[i].name >> arr[i].id>>arr[i].score;
sort(arr.begin(), arr.end(), cmp);
cout << arr[0].name << ' ' << arr[0].id << endl
<< arr[n - 1].name << ' ' << arr[n - 1].id;
return 0;
}