题目
给定一个 n 个点 m 条边的有向图,图中可能存在重边和自环, 边权可能为负数。
请你判断图中是否存在负权回路。
输入格式
第一行包含整数 n 和 m。
接下来 m 行每行包含三个整数 x,y,z,表示存在一条从点 x 到点 y 的有向边,边长为 z。
输出格式
如果图中存在负权回路,则输出 Yes
,否则输出 No
。
数据范围
1≤n≤2000,
1≤m≤10000,
图中涉及边长绝对值均不超过 10000。
输入样例:
3 3
1 2 -1
2 3 4
3 1 -4
输出样例:
Yes
解
#include<iostream>
#include<cstring>
#include<queue>
#include<algorithm>
using namespace std;
const int N = 2010, M = 1e5 + 10;
int e[M], ne[M], h[N], w[M], idx;
int dist[N], cnt[N];//cnt[]用于记录到达这个点最短路径所需要的边数
bool st[N];
int n, m;
//连接边操作
void add(int a, int b, int c){
e[idx] = b, w[idx] = c, ne[idx] = h[a], h[a] = idx++;
}
bool spfa(){
queue<int> q;
//让全部点入队,避免存在从1开始无法到达情况
for(int i = 1; i <= n; i++){
q.push(i);
st[i] = true;
}
while(q.size()){//老样子,宽搜
auto t = q.front();
q.pop();
st[t] = false;//记得让让它出列
for(int i = h[t]; i != -1; i = ne[i]){
int j = e[i];
if(dist[j] > dist[t] + w[i]){
dist[j] = dist[t] + w[i];
cnt[j] = cnt[t] + 1;
//如果到达这个点需要走n条边,根据抽屉原理一定有负权环
if(cnt[j] >= n)return true;
if(!st[j]){
st[j] = true;
q.push(j);
}
}
}
}
return false;//遍历完,不存在负权环
}
int main(){
scanf("%d%d", &n, &m);
memset(h, -1, sizeof h);
while(m--){
int a, b, c;
scanf("%d%d%d", &a, &b, &c);
add(a, b, c);
}
if(spfa())printf("Yes");
else printf("No");
return 0;
}