题目描述
从键盘输入若干个学生的信息,每个学生信息包括学号、姓名、3门课的成绩,计算每个学生的总分,输出总分最高的学生的信息。
输入
首先输入一个整数n(1<=n<=100),表示学生人数,然后输入n行,每行包含一个学生的信息:学号(12位)、姓名(不含空格且不超过20位),以及三个整数,表示语文、数学、英语三门课成绩,数据之间用空格隔开。
输出
输出总成绩最高的学生的学号、姓名、及三门课成绩,用空格隔开。若有多个最高分,只输出第一个。
样例输入 Copy
3 541207010188 Zhangling 89 78 95 541207010189 Wangli 85 87 99 541207010190 Fangfang 85 68 76
样例输出 Copy
541207010189 Wangli 85 87 99
#include <stdio.h>
#include <string.h>
struct Student{
char num[20];
char name[25];
int score[3];
}students[200];//定义结构数组
int main(){
int i,n;
scanf("%d",&n);
getchar();
for(i=0; i<n; i++){
scanf("%s%s%d%d%d",
students[i].num,students[i].name,&students[i].score[0],&students[i].score[1],&students[i].score[2]);
}
int max=students[i].score[0]+students[i].score[1]+students[i].score[2];
int index=0;
for(i=1; i<n; i++){
int t=students[i].score[0]+students[i].score[1]+students[i].score[2];
if(t>max){
max=t;
index=i;
}
}
printf("%s %s %d %d %d\n",
students[index].num,students[index].name,students[index].score[0],students[index].score[1],students[index].score[2]);
return 0;
}