OSPF实验

实验要求:

要求:
1.如图连接,合理规划IP地址,所有路由器各自创建一个loopback接口
2.R1再创建三个接口IP地址为201.1.1.1/24、201.1.2.1/24、201.1.3.1/24
R5再创建三个接口IP地址为202.1.1.1/24、202.1.2.1/24、202.1.3.1/24
R7再创建三个接口IP地址为203.1.1.1/24、203.1.2.1/24、203.1.3.1/24
3.如图运行路由协议
R1 -R2 -R3之间使用MGRE网络,为hub-spoke 网络结构,R1为hub端 ,
部署OSPF网络,MGRE修改为BMA网络类型
4.area 1 区域不得出现4.5类LSA
5.其他区域优先通过R3访问R1 三个环回接口
6.尽量减少路由条目数量
7.area 1 区域增加安全性

8.全网可达

 参数配置:

R1

#
 sysname r1
#
 snmp-agent local-engineid 800007DB03000000000000
 snmp-agent 
#
 clock timezone China-Standard-Time minus 08:00:00
#
portal local-server load portalpage.zip
#
 drop illegal-mac alarm
#
 set cpu-usage threshold 80 restore 75
#
aaa 
 authentication-scheme default
 authorization-scheme default
 accounting-scheme default
 domain default 
 domain default_admin 
 local-user admin password cipher %$%$K8m.Nt84DZ}e#<0`8bmE3Uw}%$%$
 local-user admin service-type http
#
firewall zone Local
 priority 15
#
interface GigabitEthernet0/0/0
 ip address 18.0.0.1 255.255.255.0 
#
interface GigabitEthernet0/0/1
#
interface GigabitEthernet0/0/2
#
interface NULL0
#
interface LoopBack0
 ip address 1.1.1.1 255.255.255.0 
 ospf network-type broadcast
#
interface LoopBack1
 ip address 201.1.1.1 255.255.255.0 
 ospf network-type broadcast
#
interface LoopBack2
 ip address 201.1.2.1 255.255.255.0 
 ospf network-type broadcast
#
interface LoopBack3
 ip address 201.1.3.1 255.255.255.0 
 ospf network-type broadcast
#
interface Tunnel0/0/0
 ip address 100.0.0.1 255.255.255.0 
 tunnel-protocol gre p2mp
 source 18.0.0.1
 ospf network-type broadcast
 nhrp entry multicast dynamic
 nhrp network-id 100
#
ospf 1 router-id 91.1.1.1 
 area 0.0.0.0 
  network 1.1.1.1 0.0.0.0 
  network 100.0.0.1 0.0.0.0 
  network 201.1.0.0 0.0.255.255 
#
ip route-static 0.0.0.0 0.0.0.0 18.0.0.2

R2

#
 sysname r2
#
 board add 0/4 2SA 
#
 snmp-agent local-engineid 800007DB03000000000000
 snmp-agent 
#
 clock timezone China-Standard-Time minus 08:00:00
#
portal local-server load portalpage.zip
#
 drop illegal-mac alarm
#
 set cpu-usage threshold 80 restore 75
#
aaa 
 authentication-scheme default
 authorization-scheme default
 accounting-scheme default
 domain default 
 domain default_admin 
 local-user admin password cipher %$%$K8m.Nt84DZ}e#<0`8bmE3Uw}%$%$
 local-user admin service-type http
#
firewall zone Local
 priority 15
#
interface Serial4/0/0
 link-protocol ppp
 ip address 24.0.0.1 255.255.255.0 
#
interface Serial4/0/1
 link-protocol ppp
#
interface GigabitEthernet0/0/0
 ip address 28.0.0.2 255.255.255.0 
#
interface GigabitEthernet0/0/1
#
interface GigabitEthernet0/0/2
#
interface NULL0
#
interface LoopBack0
 ip address 2.2.2.2 255.255.255.0 
 ospf network-type broadcast
#
interface Tunnel0/0/0
 ip address 100.0.0.2 255.255.255.0 
 tunnel-protocol gre p2mp
 source 28.0.0.2
 ospf network-type broadcast
 ospf dr-priority 0
 nhrp network-id 100
 nhrp entry 100.0.0.1 18.0.0.1 register
#
interface Tunnel0/0/1
 ip address 10.0.0.1 255.255.255.0 
 tunnel-protocol gre
 source 2.2.2.2
 destination 4.4.4.4
#
ospf 1 router-id 92.1.1.1 
 area 0.0.0.0 
  abr-summary 201.1.0.0 255.255.252.0 cost 10 
  abr-summary 1.1.1.0 255.255.255.0 cost 10 
  network 10.0.0.1 0.0.0.0 
  network 100.0.0.2 0.0.0.0 
 area 0.0.0.1 
  network 2.2.2.2 0.0.0.0 
  network 24.0.0.1 0.0.0.0 
  nssa
#
ip route-static 0.0.0.0 0.0.0.0 28.0.0.1

R3

#
 sysname r3
#
 board add 0/4 2SA 
#
 snmp-agent local-engineid 800007DB03000000000000
 snmp-agent 
#
 clock timezone China-Standard-Time minus 08:00:00
#
portal local-server load portalpage.zip
#
 drop illegal-mac alarm
#
 set cpu-usage threshold 80 restore 75
#
aaa 
 authentication-scheme default
 authorization-scheme default
 accounting-scheme default
 domain default 
 domain default_admin 
 local-user admin password cipher %$%$K8m.Nt84DZ}e#<0`8bmE3Uw}%$%$
 local-user admin service-type http
#
firewall zone Local
 priority 15
#
interface Serial4/0/0
 link-protocol ppp
 ip address 34.0.0.1 255.255.255.0 
#
interface Serial4/0/1
 link-protocol ppp
#
interface GigabitEthernet0/0/0
 ip address 38.0.0.2 255.255.255.0 
#
interface GigabitEthernet0/0/1
#
interface GigabitEthernet0/0/2
#
interface NULL0
#
interface LoopBack0
 ip address 3.3.3.3 255.255.255.0 
 ospf network-type broadcast
#
interface Tunnel0/0/0
 ip address 100.0.0.3 255.255.255.0 
 tunnel-protocol gre p2mp
 source 38.0.0.2
 ospf network-type broadcast
 ospf dr-priority 0
 nhrp network-id 100
 nhrp entry 100.0.0.1 18.0.0.1 register
#
interface Tunnel0/0/1
 ip address 20.0.0.1 255.255.255.0 
 tunnel-protocol gre
 source 3.3.3.3
 destination 4.4.4.4
#
ospf 1 router-id 93.1.1.1 
 area 0.0.0.0 
  abr-summary 201.1.0.0 255.255.252.0 cost 5 
  abr-summary 1.1.1.0 255.255.255.0 cost 5 
  network 20.0.0.1 0.0.0.0 
  network 100.0.0.3 0.0.0.0 
 area 0.0.0.1 
  network 3.3.3.3 0.0.0.0 
  network 34.0.0.1 0.0.0.0 
  nssa
#
ip route-static 0.0.0.0 0.0.0.0 38.0.0.1

R4

#
 sysname r4
#
 board add 0/3 2SA 
 board add 0/4 1GEC 
#
 snmp-agent local-engineid 800007DB03000000000000
 snmp-agent 
#
 clock timezone China-Standard-Time minus 08:00:00
#
portal local-server load portalpage.zip
#
 drop illegal-mac alarm
#
 set cpu-usage threshold 80 restore 75
#
aaa 
 authentication-scheme default
 authorization-scheme default
 accounting-scheme default
 domain default 
 domain default_admin 
 local-user admin password cipher %$%$K8m.Nt84DZ}e#<0`8bmE3Uw}%$%$
 local-user admin service-type http
#
firewall zone Local
 priority 15
#
interface Serial3/0/0
 link-protocol ppp
 ip address 24.0.0.2 255.255.255.0 
#
interface Serial3/0/1
 link-protocol ppp
 ip address 34.0.0.2 255.255.255.0 
#
interface GigabitEthernet0/0/0
#
interface GigabitEthernet0/0/1
 ip address 46.0.0.1 255.255.255.0 
#
interface GigabitEthernet0/0/2
 ip address 45.0.0.1 255.255.255.0 
#
interface GigabitEthernet4/0/0
#
interface NULL0
#
interface LoopBack0
 ip address 4.4.4.4 255.255.255.0 
 ospf network-type broadcast
#
interface Tunnel0/0/0
 ip address 10.0.0.2 255.255.255.0 
 tunnel-protocol gre
 source 4.4.4.4
 destination 2.2.2.2
#
interface Tunnel0/0/1
 ip address 20.0.0.2 255.255.255.0 
 tunnel-protocol gre
 source 4.4.4.4
 destination 3.3.3.3
#
ospf 1 router-id 94.1.1.1 
 asbr-summary 202.1.0.0 255.255.252.0
 import-route rip 200
 area 0.0.0.0 
  network 10.0.0.2 0.0.0.0 
  network 20.0.0.2 0.0.0.0 
 area 0.0.0.1 
  network 4.4.4.4 0.0.0.0 
  network 24.0.0.2 0.0.0.0 
  network 34.0.0.2 0.0.0.0 
  nssa no-import-route
 area 0.0.0.2 
  network 46.0.0.1 0.0.0.0 
#
rip 200
 default-route originate
 version 2
 network 45.0.0.0

R5

#
 sysname r5
#
 snmp-agent local-engineid 800007DB03000000000000
 snmp-agent 
#
 clock timezone China-Standard-Time minus 08:00:00
#
portal local-server load portalpage.zip
#
 drop illegal-mac alarm
#
 set cpu-usage threshold 80 restore 75
#
aaa 
 authentication-scheme default
 authorization-scheme default
 accounting-scheme default
 domain default 
 domain default_admin 
 local-user admin password cipher %$%$K8m.Nt84DZ}e#<0`8bmE3Uw}%$%$
 local-user admin service-type http
#
firewall zone Local
 priority 15
#
interface GigabitEthernet0/0/0
 ip address 45.0.0.2 255.255.255.0 
#
interface GigabitEthernet0/0/1
#
interface GigabitEthernet0/0/2
#
interface NULL0
#
interface LoopBack0
 ip address 5.5.5.5 255.255.255.0 
#
interface LoopBack1
 ip address 202.1.1.1 255.255.255.0 
#
interface LoopBack2
 ip address 202.1.2.1 255.255.255.0 
#
interface LoopBack3
 ip address 202.1.3.1 255.255.255.0 
#
rip 200
 version 2
 network 45.0.0.0
 network 5.0.0.0
 network 202.1.1.0
 network 202.1.2.0
 network 202.1.3.0
#

R6

#
 sysname r6
#
 snmp-agent local-engineid 800007DB03000000000000
 snmp-agent 
#
 clock timezone China-Standard-Time minus 08:00:00
#
portal local-server load portalpage.zip
#
 drop illegal-mac alarm
#
 set cpu-usage threshold 80 restore 75
#
aaa 
 authentication-scheme default
 authorization-scheme default
 accounting-scheme default
 domain default 
 domain default_admin 
 local-user admin password cipher %$%$K8m.Nt84DZ}e#<0`8bmE3Uw}%$%$
 local-user admin service-type http
#
firewall zone Local
 priority 15
#
interface GigabitEthernet0/0/0
 ip address 46.0.0.2 255.255.255.0 
#
interface GigabitEthernet0/0/1
 ip address 67.0.0.1 255.255.255.0 
#
interface GigabitEthernet0/0/2
#
interface NULL0
#
interface LoopBack0
 ip address 6.6.6.6 255.255.255.0 
 ospf network-type broadcast
#
ospf 1 router-id 96.1.1.1 
 asbr-summary 203.1.0.0 255.255.252.0
 import-route rip 100
 area 0.0.0.2 
  network 6.6.6.6 0.0.0.0 
  network 46.0.0.2 0.0.0.0 
#
rip 100
 default-route originate
 version 2
 network 67.0.0.0

R7

#
 sysname r7
#
 snmp-agent local-engineid 800007DB03000000000000
 snmp-agent 
#
 clock timezone China-Standard-Time minus 08:00:00
#
portal local-server load portalpage.zip
#
 drop illegal-mac alarm
#
 set cpu-usage threshold 80 restore 75
#
aaa 
 authentication-scheme default
 authorization-scheme default
 accounting-scheme default
 domain default 
 domain default_admin 
 local-user admin password cipher %$%$K8m.Nt84DZ}e#<0`8bmE3Uw}%$%$
 local-user admin service-type http
#
firewall zone Local
 priority 15
#
interface GigabitEthernet0/0/0
 ip address 67.0.0.2 255.255.255.0 
#
interface GigabitEthernet0/0/1
#
interface GigabitEthernet0/0/2
#
interface NULL0
#
interface LoopBack0
 ip address 7.7.7.7 255.255.255.0 
#
interface LoopBack1
 ip address 203.1.1.1 255.255.255.0 
#
interface LoopBack2
 ip address 203.1.2.1 255.255.255.0 
#
interface LoopBack3
 ip address 203.1.3.1 255.255.255.0 
#
rip 100
 version 2
 network 67.0.0.0
 network 7.0.0.0
 network 203.1.1.0
 network 203.1.2.0
 network 203.1.3.0

R8

#
 sysname r8
#
 snmp-agent local-engineid 800007DB03000000000000
 snmp-agent 
#
 clock timezone China-Standard-Time minus 08:00:00
#
portal local-server load portalpage.zip
#
 drop illegal-mac alarm
#
 set cpu-usage threshold 80 restore 75
#
aaa 
 authentication-scheme default
 authorization-scheme default
 accounting-scheme default
 domain default 
 domain default_admin 
 local-user admin password cipher %$%$K8m.Nt84DZ}e#<0`8bmE3Uw}%$%$
 local-user admin service-type http
#
firewall zone Local
 priority 15
#
interface GigabitEthernet0/0/0
 ip address 18.0.0.2 255.255.255.0 
#
interface GigabitEthernet0/0/1
 ip address 28.0.0.1 255.255.255.0 
#
interface GigabitEthernet0/0/2
 ip address 38.0.0.1 255.255.255.0 
#
interface NULL0
#
interface LoopBack0
 ip address 8.8.8.8 255.255.255.0 

实验结果

 

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值