Is Derek lying?-2017 暑期组队训练赛1-HDU-

Derek Derek and  Alfia Alfia are good friends. Derek Derek is Chinese,and  Alfia Alfia is Austrian.This summer holiday,they both participate in the summer camp of Borussia Dortmund.During the summer camp,there will be fan tests at intervals.The test consists of  N N choice questions and each question is followed by three choices marked “ A A” “ B B” and “ C C”.Each question has only one correct answer and each question is worth  1 1point.It means that if your answer for this question is right,you can get  1 1point.The total score of a person is the sum of marks for all questions.When the test is over,the computer will tell  Derek Derek the total score of him and  Alfia Alfia.Then  Alfia Alfia will ask  Derek Derek the total score of her and he will tell her: “My total score is  X X,your total score is  Y Y.”But  Derek Derek is naughty,sometimes he may lie to her. Here give you the answer that  Derek Derek and  Alfia Alfia made,you should judge whether  Derek Derekis lying.If there exists a set of standard answer satisfy the total score that  Derek Derek said,you can consider he is not lying,otherwise he is lying.
Input
The first line consists of an integer  T T,represents the number of test cases. 

For each test case,there will be three lines. 

The first line consists of three integers  N N, X X, Y Y,the meaning is mentioned above. 

The second line consists of  N N characters,each character is “ A A” “ B B” or “ C C”,which represents the answer of  Derek Derek for each question. 

The third line consists of  N N characters,the same form as the second line,which represents the answer of  Alfia Alfia for each question. 

Data Range: 1N80000 1≤N≤80000, 0X,YN, 0≤X,Y≤N, Ti=1N300000 ∑i=1TN≤300000
Output
For each test case,the output will be only a line. 

Please print “ Lying Lying” if you can make sure that  Derek Derek is lying,otherwise please print “ Not lying Not lying”.
Sample Input
2
3 1 3
AAA
ABC
5 5 0
ABCBC
ACBCB
Sample Output
Not lying
Lying
#include<stdio.h>
#include<string>
#include<iostream>//暴力吧数学问题
#include<algorithm>
using namespace std;
int main()
{
	int i,sum,t,n,x,y,k1;
	while(~scanf("%d",&t))
	{
		while(t--)
		{
			sum=0;
			string s1,s2;
			scanf("%d%d%d",&n,&x,&y);
			cin>>s1;
			cin>>s2;
			for(i=0;i<n;i++)
			{
				if(s1[i]==s2[i])
				sum++;
			}
			k1=min(sum,x);//k1表示共同对的题目数量,k2表示第一个人作对的题(不是共同作对的)
			int flag=0,k2;
			for(i=k1;i>=0;i--)//枚举k1 
			{
				k2=x-i;
				if(n-sum-k2>=0)//保证答案不同的题目中第二个人可能作对的题目大于0
				{
					if(y>=i&&(i+n-sum-k2)>=y)//y要大于共同作对的题目数,同时共同做对的题目数加上第二个人可能作对的题目要大于y 
					{
						flag=1;
						break;
					}
				}
			}
			if(flag)
			printf("Not lying\n");
			else
			printf("Lying\n");
		}
	}
}







  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值