【HDU】5500Reorder the Books-(思维)

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 1823    Accepted Submission(s): 938


 

Problem Description

dxy has a collection of a series of books called "The Stories of SDOI",There are n(n≤19) books in this series.Every book has a number from 1 to n .

dxy puts these books in a book stack with the order of their numbers increasing from top to bottom. dxy takes great care of these books and no one is allowed to touch them.

One day Evensgn visited dxy's home, because dxy was dating with his girlfriend, dxy let Evensgn stay at home himself. Evensgn was curious about this series of books.So he took a look at them. He found out there was a story about "Little E&Little Q". While losing himself in the story,he disrupted the order of the books.

Knowing that dxy would be back soon,Evensgn needed to get the books ordered again.But because the books were too heavy.The only thing Evensgn could do was to take out a book from the book stack and and put it at the stack top.

Give you the order of the disordered books.Could you calculate the minimum steps Evensgn would use to reorder the books? If you could solve the problem for him,he will give you a signed book "The Stories of SDOI 9: The Story of Little E" as a gift.

 

 

Input

There are several testcases.

There is an positive integer T(T≤30) in the first line standing for the number of testcases.

For each testcase, there is an positive integer n in the first line standing for the number of books in this series.

Followed n positive integers separated by space standing for the order of the disordered books,the ith integer stands for the ith book's number(from top to bottom).


Hint:
For the first testcase:Moving in the order of book3,book2,book1 ,(4,1,2,3)→(3,4,1,2)→(2,3,4,1)→(1,2,3,4) ,and this is the best way to reorder the books.
For the second testcase:It's already ordered so there is no operation needed.

 

 

Output

For each testcase,output one line for an integer standing for the minimum steps Evensgn would use to reorder the books.

 

 

Sample Input

 

2 4 4 1 2 3 5 1 2 3 4 5

 

 

Sample Output

 

3 0

 

 

Source

BestCoder Round #59 (div.1)

 

 

Recommend

hujie

 

 

题目大意:有N本书,现在这N本书是无序的,你可以从中间拿出一本放到最顶,问最少拿几次可以吧这个无序的书重新整理好,书的编号为从1-N

思路:首先大体的思路是这样的,如果某个数比如5,在他的后面有4,那么这个时候你就要至少拿一次把书拿到5的前面,

实现的时候,我们可以用一个数组保存一个数的位置,最后查找的时候从大数向小数查找,因为书的序号是从1-n的,经过排序的书就不需要再次排序了,所以直接将她的位置弄成0就可以了,注意一些细节很快就做出来吧。

代码:

#include<iostream>
#include<cstring>
#include<cstdio>
#include<algorithm>
using namespace std;
int a[25];
int index[25];
int main()
{
    int t,n,ans;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&a[i]);
            index[a[i]]=i;
        }

        ans=0;
        for(int i=n;i>=1;i--)
        {
            int v=i-1; //往后判断某个书的前一个书是否在他的后面
            for(int j=index[i]+1;j<=n;j++)
            {
                if(a[j]==v)
                {
                    ans++;
                    index[a[j]]=0;
                    break;
                }
            }
        }
        printf("%d\n",ans);
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值