【HDU】5606 tree(并差集)

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1897    Accepted Submission(s): 807


 

Problem Description

There is a tree(the tree is a connected graph which contains n points and n−1 edges),the points are labeled from 1 to n ,which edge has a weight from 0 to 1,for every point i∈[1,n] ,you should find the number of the points which are closest to it,the clostest points can contain i itself.

 

 

Input

the first line contains a number T,means T test cases.

for each test case,the first line is a nubmer n ,means the number of the points,next n-1 lines,each line contains three numbers u,v,w ,which shows an edge and its weight.

T≤50,n≤105,u,v∈[1,n],w∈[0,1]

 

 

Output

for each test case,you need to print the answer to each point.

in consideration of the large output,imagine ansi is the answer to point i ,you only need to output,ans1 xor ans2 xor ans3.. ansn .

 

 

Sample Input

 

1 3 1 2 0 2 3 1

 

 

Sample Output

 

1 in the sample. $ans_1=2$ $ans_2=2$ $ans_3=1$ $2~xor~2~xor~1=1$,so you need to output 1.

 

 

Source

BestCoder Round #68 (div.2)

 

 

Recommend

hujie   |   We have carefully selected several similar problems for you:  6460 6459 6458 6457 6456 

题目大意:给你N个点,给你N-1条边,每条边的长度是0或1,然后求出每个点距离最近的点的数目,也就是把长度为0的并起来,还有自己到自己的距离也是0,所以每个点距离最近的点的数目最少是1,最后把每个点的最近的点的数目去异或运算就行了, 

#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<iostream>
using namespace std;

int pre[1000003];
int num[1000003];
int find(int x)
{
    return x==pre[x]?x:pre[x]=find(pre[x] );
}
void bind(int x,int y)
{
    int a=find(x);
    int b=find(y);
    if(a!=b)
    {
        pre[a]=b;
        num[b]+=num[a];
    }
}
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        int n;
        scanf("%d",&n);
        for(int i=1;i<=100003;i++)
            pre[i]=i,num[i]=1;
        for(int i=1; i<n; i++)
        {
            int a,b,c;
            scanf("%d%d%d",&a,&b,&c);
            if(c==0)
            {
                bind(a,b);
            }
        }
        int ans=0;
        for(int i=1; i<=n; i++)
        {
            ans^=num[find(i)];
        }
        printf("%d\n",ans);
    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值