【HDU】4000Fruit Ninja(树状数组+思维)

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3642    Accepted Submission(s): 1113


 

Problem Description

Recently, dobby is addicted in the Fruit Ninja. As you know, dobby is a free elf, so unlike other elves, he could do whatever he wants.But the hands of the elves are somehow strange, so when he cuts the fruit, he can only make specific move of his hands. Moreover, he can only start his hand in point A, and then move to point B,then move to point C,and he must make sure that point A is the lowest, point B is the highest, and point C is in the middle. Another elf, Kreacher, is not interested in cutting fruits, but he is very interested in numbers.Now, he wonders, give you a permutation of 1 to N, how many triples that makes such a relationship can you find ? That is , how many (x,y,z) can you find such that x < z < y ?

 

 

Input

The first line contains a positive integer T(T <= 10), indicates the number of test cases.For each test case, the first line of input is a positive integer N(N <= 100,000), and the second line is a permutation of 1 to N.

 

 

Output

For each test case, ouput the number of triples as the sample below, you just need to output the result mod 100000007.

 

 

Sample Input

 

2 6 1 3 2 6 5 4 5 3 5 2 4 1

 

 

Sample Output

 

Case #1: 10 Case #2: 1

 

 

Source

2011 Multi-University Training Contest 16 - Host by TJU

 

 

Recommend

lcy

 

 

题目大意:给你一个N个数(1-N)的一个排列,求所有的i<j<k且a[i]<a[k]<a[j]的个数,也就是<小,大,中>这样的排列有多少个,

思路:这个题目要求的是<小,大,中>的这样的排列,我们可以先加上一个<小,中,大>的排列然后在减去,

最后发现是不是结果:ans=<小,大,中> + < 小,中,大>   - <小,中,大>

                                      ==》<小,比小大,比小大>  -  <小,中,大>;

弄成最后这样子就比较好算了,前面的无非就是个C(n,2),其中n是指比他大的数从中挑出两个来就可以,用树状数组,相当于是用木桶排序了,直接可以知道在他前面的有多少个数,算一下就好了

最后减去的就是顺次递增的。。。

代码:

#include <cstdio>
#include <iostream>
#include <cstring>
using namespace std;
int a, n, c[100001];
long long ans, tmp, tmp1;
 
int lowbit(int x)
{
    return x&(-x);
}
 
void update(int i)
{
	while(i<=n)
    {
        c[i]+=1;
        i+=lowbit(i);
    }
}
int sum(int i)
{
	int s=0;
	while(i>0)
    {
        s += c[i];
        i-=lowbit(i);
    }
	return s;
}
 
int main()
{
	int i, T, cnt=1;
	scanf("%d", &T);
	while(T--)
	{
		scanf("%d", &n);
		ans = 0;
		memset(c,0,sizeof(c));
		for(i=1; i<=n; i++)
		{
			scanf("%d", &a);
			update(a);
			tmp = sum(a-1);
			tmp1 = (n-a)-(i-1-tmp);
			ans -= tmp*tmp1;
			if(tmp1>=2)
				ans += tmp1*(tmp1-1)/2;
		}
		ans %=100000007;
		printf("Case #%d: %I64d\n", cnt++, ans);
	}
 
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值