【POJ】2566Bound Found(尺取法)

Time Limit: 5000MS Memory Limit: 65536K
Total Submissions: 6812 Accepted: 2202 Special Judge

Description

Signals of most probably extra-terrestrial origin have been received and digitalized by The Aeronautic and Space Administration (that must be going through a defiant phase: "But I want to use feet, not meters!"). Each signal seems to come in two parts: a sequence of n integer values and a non-negative integer t. We'll not go into details, but researchers found out that a signal encodes two integer values. These can be found as the lower and upper bound of a subrange of the sequence whose absolute value of its sum is closest to t. 

You are given the sequence of n integers and the non-negative target t. You are to find a non-empty range of the sequence (i.e. a continuous subsequence) and output its lower index l and its upper index u. The absolute value of the sum of the values of the sequence from the l-th to the u-th element (inclusive) must be at least as close to t as the absolute value of the sum of any other non-empty range.

Input

The input file contains several test cases. Each test case starts with two numbers n and k. Input is terminated by n=k=0. Otherwise, 1<=n<=100000 and there follow n integers with absolute values <=10000 which constitute the sequence. Then follow k queries for this sequence. Each query is a target t with 0<=t<=1000000000.

Output

For each query output 3 numbers on a line: some closest absolute sum and the lower and upper indices of some range where this absolute sum is achieved. Possible indices start with 1 and go up to n.

Sample Input

5 1
-10 -5 0 5 10
3
10 2
-9 8 -7 6 -5 4 -3 2 -1 0
5 11
15 2
-1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1
15 100
0 0

Sample Output

5 4 4
5 2 8
9 1 1
15 1 15
15 1 15

Source

Ulm Local 2001

题目大意: 给你一个序列,然后有k次查询,让你找一个子序列绝对值最接近t的序列

思路: 尺取,但是要保证数列的单调性,但是序列中有负数,要给前缀排序一下就可以了,

就是下面这样子,然后对sum排序,但是要弄一个能标记下标的东西,这里我使用了pair

下面就看代码吧,

#include<iostream>
#include<cstring>
#include<cstdio>
#include<algorithm>
#define ll long long
using namespace std;
const int maxn=110000;
int n;
pair<ll,int >sum[maxn];
void findset(int t)
{
    int l=0,r=1;
    ll ans=1e18;
    int st,en,val,temp;
    while(r<=n&&ans)
    {
        temp=sum[r].first-sum[l].first;
        if(abs(temp-t)<ans)
        {
            st=sum[l].second,en=sum[r].second;
            val=temp;
            ans=abs(temp-t);
        }
        if(temp>t)
            l++;
        if(temp<t)
            r++;
        if(l==r)
            r++;
    }
    if(st>en)
    {
        temp=st;
        st=en;
        en=temp;

    }
    printf("%d %d %d\n",val,st+1,en);
}

int main()
{
    int k;
    while(scanf("%d%d",&n,&k)&&n+k)
    {
        ll sum1=0;
        sum[0]=make_pair(0,0);
        for(int i=1; i<=n; i++)
        {
            ll x;
            scanf("%lld",&x);
            sum1+=x;
            sum[i]=make_pair(sum1,i);
        }
        sort(sum,sum+n+1);
        while(k--)
        {
            int t;
            scanf("%d",&t);
            findset(t);
        }
    }
}

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值