【POJ】1456Supermarket(并差集思想处理贪心问题)

Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 18540 Accepted: 8360

Description

A supermarket has a set Prod of products on sale. It earns a profit px for each product x∈Prod sold by a deadline dx that is measured as an integral number of time units starting from the moment the sale begins. Each product takes precisely one unit of time for being sold. A selling schedule is an ordered subset of products Sell ≤ Prod such that the selling of each product x∈Sell, according to the ordering of Sell, completes before the deadline dx or just when dx expires. The profit of the selling schedule is Profit(Sell)=Σx∈Sellpx. An optimal selling schedule is a schedule with a maximum profit. 
For example, consider the products Prod={a,b,c,d} with (pa,da)=(50,2), (pb,db)=(10,1), (pc,dc)=(20,2), and (pd,dd)=(30,1). The possible selling schedules are listed in table 1. For instance, the schedule Sell={d,a} shows that the selling of product d starts at time 0 and ends at time 1, while the selling of product a starts at time 1 and ends at time 2. Each of these products is sold by its deadline. Sell is the optimal schedule and its profit is 80. 


Write a program that reads sets of products from an input text file and computes the profit of an optimal selling schedule for each set of products. 

Input

A set of products starts with an integer 0 <= n <= 10000, which is the number of products in the set, and continues with n pairs pi di of integers, 1 <= pi <= 10000 and 1 <= di <= 10000, that designate the profit and the selling deadline of the i-th product. White spaces can occur freely in input. Input data terminate with an end of file and are guaranteed correct.

Output

For each set of products, the program prints on the standard output the profit of an optimal selling schedule for the set. Each result is printed from the beginning of a separate line.

Sample Input

4  50 2  10 1   20 2   30 1

7  20 1   2 1   10 3  100 2   8 2
   5 20  50 10

Sample Output

80
185

Hint

The sample input contains two product sets. The first set encodes the products from table 1. The second set is for 7 products. The profit of an optimal schedule for these products is 185.

Source

题目大意:会给出一个N,也就是N组数据,其中每组数据分别代表了一个物品的价格和到期时间。到期了就不能再出售了,也就得不到钱了,而且这个商店每天只会卖出去1件物品,问你这些商品的最大卖出去的价格是多少,

思路:我们这样考虑,我们先将所有物品按照价格从大到下进行排序,然后从第一个开始累加,这个累加的条件也就是这个物品还没有过期,

那么我们怎样实现这个过程呢,想起并差集,我们可以每个物品的F值都设置为自己的过期时间,如果如果某个物品的过期时间与他是相同的,我们就将他的过期时间-1,这样就可以达到:比如说过期期限是两天的,就一定卖不出去三件,

详情看代码吧,。

#include<iostream>
#include<algorithm>
#include<cstdio>
#include<cstring>
#include<cstdio>
#include<map>
using namespace std;
const int maxn=10000+10;
int F[maxn];
struct node
{
    int p,d;
}a[maxn];
bool cmp(node a,node b)
{
    return a.p>b.p;
}
int findset(int x)
{
    if(F[x]==-1) return x;
    return F[x]=findset(F[x]);
}

int main()
{
    int n;
    while(scanf("%d",&n)!=EOF)
    {
        memset(F,-1,sizeof(F));
        for(int i=0;i<n;i++)
            scanf("%d%d",&a[i].p,&a[i].d);
        sort(a,a+n,cmp);
        int ans=0;
        for(int i=0;i<n;i++)
        {
            int k=findset(a[i].d);
            if(k>0)
            {
                ans+=a[i].p;
                F[k]=k-1;
            }
        }
        printf("%d\n",ans);
    }
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值