Cube Stacking----并查集变形运用

Description

Farmer John and Betsy are playing a game with N (1 <= N <= 30,000)identical cubes labeled 1 through N. They start with N stacks, each containing a single cube. Farmer John asks Betsy to perform P (1<= P <= 100,000) operation. There are two types of operations:
moves and counts.
* In a move operation, Farmer John asks Bessie to move the stack containing cube X on top of the stack containing cube Y.
* In a count operation, Farmer John asks Bessie to count the number of cubes on the stack with cube X that are under the cube X and report that value.

Write a program that can verify the results of the game.

Input

* Line 1: A single integer, P

* Lines 2..P+1: Each of these lines describes a legal operation. Line 2 describes the first operation, etc. Each line begins with a 'M' for a move operation or a 'C' for a count operation. For move operations, the line also contains two integers: X and Y.For count operations, the line also contains a single integer: X.

Note that the value for N does not appear in the input file. No move operation will request a move a stack onto itself.

Output

Print the output from each of the count operations in the same order as the input file.

Sample Input

6
M 1 6
C 1
M 2 4
M 2 6
C 3
C 4

Sample Output

1
0
2

AC:

#include<cstdio>
using namespace std;

int const N = 30005;
int fa[N],dis[N],len[N];

void init(){
    for(int i = 1; i <= N;i++){
        fa[i] = i;
        dis[i] = 0;
        len[i] = 1;
    }
}

int find(int x){
    if(fa[x] == x)return x;
    int fx = find(fa[x]);
    dis[x] += dis[fa[x]];
    fa[x] = fx;
    return fx;
}

void merge(int x,int y){
    int fx,fy;
    fx = find(x);
    fy = find(y);
    if(fx != fy){
        fa[fx] = fy;
        dis[fx] += len[fy];
        len[fy] += len[fx]; 
    }
}

int main(){
    int p,x,y;
    char c;
    init();
    scanf("%d",&p);
    for(int i = 1;i <= p;i++){
        scanf(" %c%d",&c,&x);
        if(c == 'M'){
            scanf("%d",&y);
            merge(x,y);
        }else{
            find(x);
            printf("%d\n",dis[x]);
        }
    }
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值