hdu 2102 A计划

13 篇文章 0 订阅

A计划

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 7024    Accepted Submission(s): 1638


Problem Description
可怜的公主在一次次被魔王掳走一次次被骑士们救回来之后,而今,不幸的她再一次面临生命的考验。魔王已经发出消息说将在T时刻吃掉公主,因为他听信谣言说吃公主的肉也能长生不老。年迈的国王正是心急如焚,告招天下勇士来拯救公主。不过公主早已习以为常,她深信智勇的骑士LJ肯定能将她救出。
现据密探所报,公主被关在一个两层的迷宫里,迷宫的入口是S(0,0,0),公主的位置用P表示,时空传输机用#表示,墙用*表示,平地用.表示。骑士们一进入时空传输机就会被转到另一层的相对位置,但如果被转到的位置是墙的话,那骑士们就会被撞死。骑士们在一层中只能前后左右移动,每移动一格花1时刻。层间的移动只能通过时空传输机,且不需要任何时间。
 

Input
输入的第一行C表示共有C个测试数据,每个测试数据的前一行有三个整数N,M,T。 N,M迷宫的大小N*M(1 <= N,M <=10)。T如上所意。接下去的前N*M表示迷宫的第一层的布置情况,后N*M表示迷宫第二层的布置情况。
 

Output
如果骑士们能够在T时刻能找到公主就输出“YES”,否则输出“NO”。
 

Sample Input
  
  
1 5 5 14 S*#*. .#... ..... ****. ...#. ..*.P #.*.. ***.. ...*. *.#..
 

Sample Output
  
  
YES
注意:如果遇到#,若对面同为#或*,则不能标记为不能走,还有就是题目意思是时光机移动不需要时间,层间移动移动还是需要时间的....
AC代码:
#include <iostream>
#include <cstring>
#include <cstdio>
#include <queue>
#include <cmath>
#include <string>
#include <algorithm>
using namespace std;
struct node
{
    int x,y;
    int step;
    int a;
}start;
int d[4][2]= {{1,0},{-1,0},{0,1},{0,-1}};
int n,m,T,ex,ey,ez;
char map[2][15][15];

bool bfs()
{
    start.x=0;
    start.y=0;
    start.step=0;
    start.a=0;
    node first,next;
    queue<node>q;
    map[0][0][0]='*';
    q.push(start);
    while(!q.empty())
    {
        first=q.front();
        q.pop();
        if(first.step>T) break;
        if(first.x==ex&&first.y==ey&&first.a==ez&&first.step<=T)
            return true;
        for(int i=0; i<4; i++)
        {
            next=first;
            next.x+=d[i][0];
            next.y+=d[i][1];
            ++next.step;
            if(next.x<0||next.x>=n||next.y<0||next.y>=m) continue;
            if(map[next.a][next.x][next.y]=='#')
            {
                map[next.a][next.x][next.y]='*';
                next.a^=1;
                if(map[next.a][next.x][next.y]=='#')
                {
                    map[next.a][next.x][next.y]='*';
                    continue;
                }
            }
            if(map[next.a][next.x][next.y]=='.'||map[next.a][next.x][next.y]=='P')
            {
                map[next.a][next.x][next.y]='*';    //如果是终点把终点设为*,若最后用map[][][]来判断,明显是不对的
                q.push(next);
            }
        }
    }
    return false;
}
int main()
{
    int t;
    cin>>t;
    while(t--)
    {
        cin>>n>>m>>T;
        for(int k=0; k<2; k++)
            for(int i=0; i<n; i++)
                for(int j=0; j<m; j++)
                    {cin>>map[k][i][j];
                    if(map[k][i][j]=='P')
                    {
                        ez=k;
                        ex=i;
                        ey=j;
                    }
                    }
        if(bfs())
            cout<<"YES"<<endl;
        else
            cout<<"NO"<<endl;
    }
    return 0;
}


 

评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值