hdu 统计难题

统计难题

Time Limit : 4000/2000ms (Java/Other)   Memory Limit : 131070/65535K (Java/Other)
Total Submission(s) : 2   Accepted Submission(s) : 2
Problem Description
Ignatius最近遇到一个难题,老师交给他很多单词(只有小写字母组成,不会有重复的单词出现),现在老师要他统计出以某个字符串为前缀的单词数量(单词本身也是自己的前缀).
 


 

Input
输入数据的第一部分是一张单词表,每行一个单词,单词的长度不超过10,它们代表的是老师交给Ignatius统计的单词,一个空行代表单词表的结束.第二部分是一连串的提问,每行一个提问,每个提问都是一个字符串.

注意:本题只有一组测试数据,处理到文件结束.
 


 

Output
对于每个提问,给出以该字符串为前缀的单词的数量.
 


 

Sample Input
  
  
banana band bee absolute acm ba b band abc
 


 

Sample Output
  
  
2 3 1 0

 

很多字典树的问题都可以用集合来做,集合做起来方便,容易实现
import java.util.Scanner;

public class HduTest1 {
	
	public static Node root = null;

	public static void main(String[] args) {
		Scanner sc = new Scanner(System.in);
		String str = "";
		root = new HduTest1().new Node(); 
		while(sc.hasNextLine()) {
			str = sc.nextLine();
			if(str.length()==0) {
				break;
			}
			createTree(str);
		}
		while(sc.hasNextLine()) {
			str = sc.nextLine();
			int result = search(str);
			System.out.println(result);
		}
	}
	
	private static int search(String str) {
		Node tempNode = root;
		int result = 0;
		int ch = 0;
		for(int i=0; i<str.length(); i++) {
			ch = str.charAt(i) - 'a';
			if(tempNode != null) {
				tempNode = tempNode.arr[ch];
			} 
		}
		if(tempNode != null) {
			result = tempNode.count;
		}
		return result;
	}


	private static void createTree(String str) {
		Node tempNode = root;
		for(int i=0; i<str.length(); i++) {
			int ch = str.charAt(i) - 'a';
			if(tempNode.arr[ch] == null) {
				tempNode.arr[ch] = new HduTest1().new Node();
			}
			tempNode = tempNode.arr[ch];
			tempNode.count ++;
		}
	}

	class Node {
		Node[] arr = new Node[26];
		int count = 0;
		public Node() {
			for(int i=0; i<26; i++) {
				arr[i] = null;
			}
		}
	}

}


 

 

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值