D - Fxx and string

Problem Description

Young theoretical computer scientist Fxx get a string which contains lowercase letters only.

The string
S contains n lowercase letters S1S2Sn .Now Fxx wants to know how many three tuple (i,j,k) there are which can meet the following conditions:

1、
i,j,k are adjacent into a geometric sequence.

2、
Si= ' y ' ,Sj= ' r ' ,Sk= ' x '.

3.Either j/i or j/k

 


Input

In the first line, there is an integer T(1T100) indicating the number of test cases.

lines follow, each line contains a string, which contains only lowercase letters.(The length of string will not exceed 10000 ).

 

 Output

For each case, output the answer.

 

Sample Input

2

xyyrxx

yyrrxxxxx


Sample Output

0

2

题意:题意:给定一个字符串,问有多少个三元组满足 i, j, k组成一个等比数列,并且s[i] = 'y', s[j] = 'r', s[k] = 'x',且j/i ,j/k中至少一个是整数。

暴力求解就ok

#include<cstdio>
#include<cstring>
using namespace std;
int main()
{
    char s[10005];
    int t;
    scanf("%d",&t);
    while(t--)
    {
        int cnt=0,i,j=2,len;
        scanf("%s",s+1);
        len=strlen(s+1);
        for(i=1;i*4<=len;i++)
        {
            //printf("%d:\n",i);
            for(j=2;i*j*j<=len;j++)
            {
                //printf("%d\n",i*j*j);
                if(s[i]=='y'&&s[i*j]=='r'&&s[i*j*j]=='x')
                    cnt++;
                if(s[i*j*j]=='y'&&s[i*j]=='r'&&s[i]=='x')
                    cnt++;
                //printf("%d\n",cnt);
            }
            //printf("%d\n",cnt);
        }
        printf("%d\n",cnt);
    }
    return 0;
}


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值