HDU 2052

Picture

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 17208    Accepted Submission(s): 8872


Problem Description
Give you the width and height of the rectangle,darw it.
 


Input
Input contains a number of test cases.For each case ,there are two numbers n and m (0 < n,m < 75)indicate the width and height of the rectangle.Iuput ends of EOF.
 


Output
For each case,you should draw a rectangle with the width and height giving in the input.
after each case, you should a blank line.
 


Sample Input
  
  
3 2
 


Sample Output
  
  
+---+ | | | | +---+
 


Author
xhd
 


Source



解题思路:

    没什么好说的,都是水题,就是画图了,分三步来画就OK了,第一步,画出第一场,扫一遍加两个+,

    第二步,就是画中间的部分了,有点技巧,a和b互相换下,然后先画|,再画空格。

    第三步,就是和画第一步的思路基本完全一致了,



代码:

# include<cstdio>
# include<iostream>

using namespace std;

int main(void)
{
    int a,b;
    while ( cin>>a>>b )
    {
        cout<<"+";
        for ( int i = 0;i < a;i++ )
        {
            cout<<"-";
        }
        cout<<"+"<<endl;
        for ( int i = 0;i < b;i++ )
        {
            cout<<"|";
            for ( int j = 0;j < a;j++ )
            {
                cout<<" ";
            }
            cout<<"|"<<endl;
        }
        cout<<"+";
        for ( int i = 0;i < a;i++ )
            cout<<"-";
        cout<<"+"<<endl;
        cout<<endl;






    }



    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值