Description
Due to recent rains, water has pooled in various places in Farmer John's field, which is represented by a rectangle of N x M (1 <= N <= 100; 1 <= M <= 100) squares. Each square contains either water ('W') or dry land ('.'). Farmer John would like to figure out how many ponds have formed in his field. A pond is a connected set of squares with water in them, where a square is considered adjacent to all eight of its neighbors.
Given a diagram of Farmer John's field, determine how many ponds he has.
Given a diagram of Farmer John's field, determine how many ponds he has.
Input
* Line 1: Two space-separated integers: N and M
* Lines 2..N+1: M characters per line representing one row of Farmer John's field. Each character is either 'W' or '.'. The characters do not have spaces between them.
* Lines 2..N+1: M characters per line representing one row of Farmer John's field. Each character is either 'W' or '.'. The characters do not have spaces between them.
Output
* Line 1: The number of ponds in Farmer John's field.
Sample Input
10 12 W........WW. .WWW.....WWW ....WW...WW. .........WW. .........W.. ..W......W.. .W.W.....WW. W.W.W.....W. .W.W......W. ..W.......W.
Sample Output
3
Hint
OUTPUT DETAILS:
There are three ponds: one in the upper left, one in the lower left,and one along the right side.
There are three ponds: one in the upper left, one in the lower left,and one along the right side.
解题思路:
就是说,给你一个图,让你找出图中的所有W组成的联通块有多少个,其实就是dfs求联通块的最简单的应用,每次找到‘W’后,就把‘W’修改成为‘.’然后,总共进行了多少次大的dfs,就说明有几个联通块了。
# include<cstdio>
# include<iostream>
# include<algorithm>
# include<cstring>
# include<string>
# include<cmath>
# include<queue>
# include<stack>
# include<set>
# include<map>
using namespace std;
# define inf 999999999
# define MAX 123
char grid[MAX][MAX];
int book[MAX][MAX];
int n,m;
int cnt;
int next[8][2] = {{1,0},{1,-1},{0,-1},{-1,-1},{-1,0},{-1,1},{0,1},{1,1}};
void input()
{
for ( int i = 0;i < n;i++ )
{
scanf("%s",grid[i]);
}
}
void dfs( int x,int y )
{
grid[x][y] = '.';
for ( int i = 0;i < 8;i++ )
{
int n_x = x+next[i][0];
int n_y = y+next[i][1];
if ( n_x>=0&&n_x<n&&n_y>=0&&n_y<m&&book[n_x][n_y]==0&&grid[n_x][n_y]=='W' )
{
dfs( n_x,n_y );
}
}
}
void solve()
{
for ( int i = 0;i < n;i++ )
{
for ( int j = 0;j < m;j++ )
{
if ( grid[i][j]=='W' )
{
dfs( i,j );
cnt++;
}
}
}
}
int main(void)
{
while ( cin>>n>>m )
{
input();
solve();
cout<<cnt<<endl;
}
return 0;
}