20140719 「树状数组 - 区间更新,区间求和」 POJ 3468 A Simple Problem with Integers

Online JudgeProblem SetAuthorsOnline ContestsUser
Web Board
Home Page
F.A.Qs
Statistical Charts
Problems
Submit Problem
Online Status
Prob.ID:
Register
Update your info
Authors ranklist
Current Contest
Past Contests
Scheduled Contests
Award Contest
wilson1068      Log Out
Mail:0(0)
Login Log      Archive
Language:
A Simple Problem with Integers
Time Limit: 5000MS Memory Limit: 131072K
Total Submissions: 58536 Accepted: 17827
Case Time Limit: 2000MS

Description

You have N integers, A1A2, ... , AN. You need to deal with two kinds of operations. One type of operation is to add some given number to each number in a given interval. The other is to ask for the sum of numbers in a given interval.

Input

The first line contains two numbers N and Q. 1 ≤ N,Q ≤ 100000.
The second line contains N numbers, the initial values of A1A2, ... , AN. -1000000000 ≤ Ai ≤ 1000000000.
Each of the next Q lines represents an operation.
"C a b c" means adding c to each of AaAa+1, ... , Ab. -10000 ≤ c ≤ 10000.
"Q a b" means querying the sum of AaAa+1, ... , Ab.

Output

You need to answer all Q commands in order. One answer in a line.

Sample Input

10 5
1 2 3 4 5 6 7 8 9 10
Q 4 4
Q 1 10
Q 2 4
C 3 6 3
Q 2 4

Sample Output

4
55
9
15

Hint

The sums may exceed the range of 32-bit integers.

Source

[Submit]   [Go Back]   [Status]   [Discuss]

Home Page   Go Back  To top


All Rights Reserved 2003-2013 Ying Fuchen,Xu Pengcheng,Xie Di
Any problem, Please Contact Administrator













#include <stdio.h>
#include <string.h>
#define MAXN 101000
#define lowbit(x) ((x)&(-x))
int n, m;
long long a[MAXN], b[MAXN], c[MAXN];

void add(long long s[], int i, int x){
    for( ; i<=n; i+=lowbit(i))  s[i] += x;
}

long long sum(long long s[], int i){
    long long ret = 0;
    for( ; i>0; i-=lowbit(i) )
        ret += s[i];
    return ret;
}

long long sum_ans(int i){
    return (i+1)*sum(b, i) - sum(c, i);
}

int main(){           
    long long L, R, x;
    while( ~scanf("%d%d", &n, &m) ){
        a[0] = 0;
        for(int i=1; i<=n; i++){
            scanf("%lld", &a[i]);
            a[i] += a[i-1];
        }
        char s[10];
        while( m-- ){
            scanf("%s", s);
            if( 'Q'==s[0] ){
                scanf("%lld%lld", &L, &R);
                long long ans = a[R]-a[L-1] +sum_ans(R)-sum_ans(L-1);
                printf("%lld\n", ans );
            }
            else {
                scanf("%lld%lld%lld", &L, &R, &x);
                add(b, L, x);                   add(b, R+1, -x);
                add(c, L, x*L);                 add(c, R+1, -x*(R+1));
            }
        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值