20141002 【 单调队列 】 hdoj 3530 Subsequence

14 篇文章 0 订阅
2 篇文章 0 订阅

F.A.Q
Hand In Hand
Online Acmers
Forum | Discuss
Statistical Charts
Problem Archive
Realtime Judge Status
Authors Ranklist
 
      C/C++/Java Exams     
ACM Steps
Go to Job
Contest LiveCast
ICPC@China
Best Coder beta
VIP | STD Contests
Virtual Contests 
    DIY | Web-DIY beta
Recent Contests
BestCoder官方群:385386683 欢迎加入~
寻人启事:2014级新生看过来!

Subsequence

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 4441    Accepted Submission(s): 1457


Problem Description
There is a sequence of integers. Your task is to find the longest subsequence that satisfies the following condition: the difference between the maximum element and the minimum element of the subsequence is no smaller than m and no larger than k.
 

Input
There are multiple test cases.
For each test case, the first line has three integers, n, m and k. n is the length of the sequence and is in the range [1, 100000]. m and k are in the range [0, 1000000]. The second line has n integers, which are all in the range [0, 1000000].
Proceed to the end of file.
 

Output
For each test case, print the length of the subsequence on a single line.
 

Sample Input
      
      
5 0 0 1 1 1 1 1 5 0 3 1 2 3 4 5
 

Sample Output
      
      
5 4
 

Source
 

Recommend
zhengfeng   |   We have carefully selected several similar problems for you:   3535  3529  3528  3527  3415 
 

Statistic |  Submit |  Discuss |  Note
Hangzhou Dianzi University Online Judge 3.0
Copyright © 2005-2014 HDU ACM Team. All Rights Reserved.
Designer & Developer Wang Rongtao LinLe GaoJie GanLu
Total 0.029372(s) query 5, Server time : 2014-10-01 18:12:56, Gzip disabled












#include <stdio.h>
#include <string.h>
#include <algorithm>
#include <queue>
using namespace std;
const int MAXN = 100000+10;
int n, m, k;
int a[MAXN];
int add[MAXN], al, ar;
int sub[MAXN], sl, sr;
int main(){
    while( EOF != scanf("%d%d%d", &n, &m, &k) ){
        int flag=al=sl=0, ans = 0;
        ar = sr = -1;                       /** 队尾指针 */
        for(int i=1; i<=n; i++){
            scanf("%d", &a[i]);
            while( sl<=sr && a[sub[sr]]>=a[i] ) sr--;/** min,大于 a[i] 的全部出队 */
            sub[++sr] = i;                              /** push min[flag] */
            while( al<=ar && a[add[ar]]<=a[i] ) ar--;/** max,小于 a[i] 的全部出队 */
            add[++ar] = i;                              /** push max[flag] */
            while( a[add[al]]-a[sub[sl]]>k )            /** 上界,弹出最左的元素 */
                if( add[al]<sub[sl] )   flag = add[al++];
                else                    flag = sub[sl++];
            if( a[add[al]]-a[sub[sl]]>=m && i-flag>ans )
                ans = i-flag;   /** flag , [ flag+1 ... i ]  // ans = i-flag */
        }
        printf("%d\n", ans);
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值