20130712 【南华大学 ACM】 新生赛第三场 【F. Help Johnny】


Problem F: Help Johnny

Time Limit: 1 Sec  Memory Limit:128 MB

Description

Poor Johnny is so busy this term. His tutor threw lots of hard problems to him and demanded him to 
accomplish those problems in a month. What a wicked tutor! After cursing his tutor thousands of times, 
Johnny realized that he must start his work immediately.  
The very problem Johnny should solve firstly is about a strange machine called Warmouth. In the Warmouth 
there are many pairs of balls. Each pair consists of a red ball and a blue ball and each ball is assigned a value. 
We can represent a pair in the form of (R, B) in which R is the value of the red ball and B is of the blue one. 
Warmouth has a generator to calculate the match value of two pairs. The match value of (R1, B1) and (R2, 
B2) is R1*B2+R2*B1. Initially, Warmouth is empty. Pairs are sent into Warmouth in order. Once a new pair 
comes, it will be taken into the generator with all the pairs already in Warmouth.  
Johnny’s work is to tell his tutor the sum of all match values given the list of pairs in order. As the best 
friend of Johnny, would you like to help him? 

Input

The first line of the input is T (no more than 10), which stands for the number of lists Johnny received.  
Each list begins with “N“(without quotes). N is the number of pairs of this list and is no more than 100000. 
The next line gives N pairs in chronological order. The 2i-th number is the value of the red ball of the i-th 
pair and the (2i+1)-th number is the value of the blue ball of the i-th pair. The numbers are positive integers 
and smaller than 100000. 

Output

Please output the result in a single line for each list.  

Sample Input

2 
3 
1 3 2 2 3 1 
2 
4 5 6 7 

Sample Output

26 
58 


----------------------------------------------------------------
解题报告:


该题嘛,统计规律(直接做会严重超时):


  1. 包含R1的:R1*B2+R1*B3+……+R1*Bn 
  2.  = R1*B1+R1*B2+R1*B3+……+R1*Bn-R1*B1 = R1*(B1+B2+……+Bn)-R1*B1
  3. 由此,可知:
  4. 包含R2的:R2* (B1+B2+……+Bn)-R2*B2
  5. 包含R3的:R3*(B1+B2+……+Bn)-R3*B3
  6.          ……                              ……
  7. 包含Rn的:Rn*(B1+B2+……+Bn)-Rn*Bn
  8. 于是,上式相加,得:所求值的表达式为:
  9.            (R1+R2+……+Rn)*(B1+B2+……+Bn)-(R1*B1+R2*B2+……+Rn*Bn)


对此,读入数据(Ri,Bi)时:

  1. 用 sum.r 累加 Ri(sum.r+=Ri);
  2. 用 sum.b 累加 Bi (sum.b+=Bi);
  3. 用 sum.rb 累加 Ri*Bi(sum.rb+=Ri*Bi);
  4. 最后,直接输出 sum.r*sum.b-sum.rb 即为所求。

----------------------------------------------------------------

代码:

#include<stdio.h>
struct sum
{
	long long r,b,rb;
}sum;

int main()
{
	int i,j,t,n,r,b;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d",&n);
		n*=2;
		sum.rb=0;	sum.r=0;	sum.b=0;
		for(i=0,j=1;j<n;i+=2,j+=2)
		{
			scanf("%d%d ",&r,&b);
			sum.r+=r;
			sum.b+=b;
			sum.rb+=r*b;
		}
		printf("%lld\n",sum.r*sum.b-sum.rb);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值