1020 Tree Traversals

Suppose that all the keys in a binary tree are distinct positive integers. Given the postorder and inorder traversal sequences, you are supposed to output the level order traversal sequence of the corresponding binary tree.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<=30), the total number of nodes in the binary tree. The second line gives the postorder sequence and the third line gives the inorder sequence. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the level order traversal sequence of the corresponding binary tree. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:
7
2 3 1 5 7 6 4
1 2 3 4 5 6 7
Sample Output:
4 1 6 3 5 7 2

解题思路:根据题目给的后序遍历和中序遍历构建树,然后对数进行层次遍历输出结果。

#include<iostream>
#include<stdio.h>
#include<queue>
using namespace std;
struct node{
    int left;
    int right;
};
node que[35];
int index = 0;
void level(int *post, int *in, int pBegin, int pEnd, int iBegin, int iEnd){
    if (pEnd == pBegin || iBegin == iEnd){
        return;
    }
    //if (pEnd - pBegin == 1){
    //  //printf("%d ", post[pBegin]);
    //  return;
    //}

    int iMid;
    for (int i = iBegin; i < iEnd; i++){
        if (in[i] == post[pEnd - 1]){
            iMid = i;
            break;
        }
    }
    int pMid = pBegin + iMid - iBegin;
    //printf("%d ", post[pEnd - 1]);
    //que[index] = post[pEnd - 1];
    //index++;
    if (pMid > pBegin){
        que[pEnd-1].left = pMid-1;
    }
    else{
        que[pEnd - 1].left = -1;
    }
    if (pEnd - 1 > pMid){
        que[pEnd-1].right = pEnd-2;
    }
    else{
        que[pEnd - 1].right = -1;
    }
    level(post, in, pBegin, pMid, iBegin, iMid);

    level(post, in, pMid, pEnd - 1, iMid + 1, iEnd);

}
int main(){
    for (int n; scanf("%d", &n) != EOF;){
        int *post = new int[n];
        int *in = new int[n];
        for (int i = 0; i < n; i++){
            scanf("%d", &post[i]);
        }
        for (int i = 0; i < n; i++){
            scanf("%d", &in[i]);
        }
        level(post, in, 0, n, 0, n);
        queue<int>out;
        printf("%d", post[n - 1]);
        if (que[n-1].left != -1)
            out.push(que[n-1].left);
        if (que[n-1].right != -1)
            out.push(que[n - 1].right);
        while (!out.empty()){
            int temp = out.front();
            out.pop();
            printf(" %d", post[temp]);
            if (que[temp].left != -1){
                out.push(que[temp].left);
            }
            if (que[temp].right != -1){
                out.push(que[temp].right);
            }
        }
        printf("\n");
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值