1095 Cars on Campus

Zhejiang University has 6 campuses and a lot of gates. From each gate we can collect the in/out times and the plate numbers of the cars crossing the gate. Now with all the information available, you are supposed to tell, at any specific time point, the number of cars parking on campus, and at the end of the day find the cars that have parked for the longest time period.

Input Specification:

Each input file contains one test case. Each case starts with two positive integers N (<= 10000), the number of records, and K (<= 80000) the number of queries. Then N lines follow, each gives a record in the format

plate_number hh:mm:ss status

where plate_number is a string of 7 English capital letters or 1-digit numbers; hh:mm:ss represents the time point in a day by hour:minute:second, with the earliest time being 00:00:00 and the latest 23:59:59; and status is either in or out.

Note that all times will be within a single day. Each “in” record is paired with the chronologically next record for the same car provided it is an “out” record. Any “in” records that are not paired with an “out” record are ignored, as are “out” records not paired with an “in” record. It is guaranteed that at least one car is well paired in the input, and no car is both “in” and “out” at the same moment. Times are recorded using a 24-hour clock.

Then K lines of queries follow, each gives a time point in the format hh:mm:ss. Note: the queries are given in ascending order of the times.

Output Specification:

For each query, output in a line the total number of cars parking on campus. The last line of output is supposed to give the plate number of the car that has parked for the longest time period, and the corresponding time length. If such a car is not unique, then output all of their plate numbers in a line in alphabetical order, separated by a space.

Sample Input:
16 7
JH007BD 18:00:01 in
ZD00001 11:30:08 out
DB8888A 13:00:00 out
ZA3Q625 23:59:50 out
ZA133CH 10:23:00 in
ZD00001 04:09:59 in
JH007BD 05:09:59 in
ZA3Q625 11:42:01 out
JH007BD 05:10:33 in
ZA3Q625 06:30:50 in
JH007BD 12:23:42 out
ZA3Q625 23:55:00 in
JH007BD 12:24:23 out
ZA133CH 17:11:22 out
JH007BD 18:07:01 out
DB8888A 06:30:50 in
05:10:00
06:30:50
11:00:00
12:23:42
14:00:00
18:00:00
23:59:00
Sample Output:
1
4
5
2
1
0
1
JH007BD ZD00001 07:20:09

**解题思路:首先对所有的记录进行筛选,保留能配对的记录,配对原则是选择时间距离最短的进行in-out匹配。对于查询,我是维护了一个数组,用于记录以秒为单位的每个事件点的状态,比如时间点x上有车进来,则对这一时刻进行++操作,有车出去则进行–操作。当查询的时候,从0开始直至查询时刻进行求和,就是当时在学校内停靠的车的数量。
查询的时候不必每次都从0开始进行求和操作,因为题目说查询的时间是按照升序进行输入的,所以保留每次求和的结果,可以被下一次查询使用,这样可以减少时间消耗,不然测试点4会运行超时。
保留求和操作的时候要注意一个点就是,第一次求和的时候是从0开始进行求和的。**

#include<iostream>
#include<vector>
#include<algorithm>
#include<map>
#include<string.h>
#include<string>
using namespace std;
struct record{
    //char plate[8];
    string plate;
    int hour;
    int minute;
    int second;
    string status;
    int totalTime = 0;
    //char status[4];
};
bool cmp(const record& r1, const record&r2){
    return r1.hour * 3600 + r1.minute * 60 + r1.second < r2.hour * 3600 + r2.minute * 60 + r2.second;
}
int carCount[100000];
int main(){
    for (int n, k; scanf("%d%d", &n, &k) != EOF;){
        memset(carCount, 0, sizeof(carCount));
        vector<string>longestCar;
        int maxTime = 0;
        map<string, vector<record>>cars;
        for (int i = 0; i < n; i++){
            record temp;
            cin >> temp.plate;
            scanf("%d:%d:%d", &temp.hour, &temp.minute, &temp.second);
            cin >> temp.status;
            cars[temp.plate].push_back(temp);
        }
        map<string, vector<record>>::iterator iter;
        for (iter = cars.begin(); iter != cars.end(); iter++){
            sort(iter->second.begin(), iter->second.end(), cmp);
            vector<record>temp;
            //printf("%s\n", iter->first);
            int tempTime = 0;
            for (int i = 0; i < iter->second.size(); i++){
                if (iter->second[i].status[0] == 'i'){
                    record start = iter->second[i];
                    for (i = i + 1; i < iter->second.size(); i++){
                        if (iter->second[i].status[0] == 'i'){
                            start = iter->second[i];
                        }
                        else{
                            temp.push_back(start);
                            carCount[start.hour * 3600 + start.minute * 60 + start.second]++;
                            record end = iter->second[i];
                            carCount[end.hour * 3600 + end.minute * 60 + end.second]--;
                            temp.push_back(end);
                            tempTime += (end.hour * 3600 + end.minute * 60 + end.second - start.hour * 3600 - start.minute * 60 - start.second);
                            break;
                        }
                    }
                }
            }
            if (tempTime > maxTime){
                longestCar.clear();
                longestCar.push_back(iter->first);
                maxTime = tempTime;
            }
            else if (tempTime == maxTime){
                longestCar.push_back(iter->first);
            }
            iter->second = temp;
        }
        int lTime = 0;
        int sum = 0;
        for (int i = 0; i < k; i++){
            int hour;
            int minute;
            int second;
            scanf("%d:%d:%d", &hour, &minute, &second);
            int qTime = hour * 3600 + minute * 60 + second;
            int j;
            if (i == 0){
                j = 0;
            }
            else{
                j = lTime + 1;
            }
            for (; j <= qTime; j++){
                sum += carCount[j];
            }
            lTime = qTime;
            printf("%d\n", sum);
        }
        sort(longestCar.begin(),longestCar.end());
        for (int i = 0; i < longestCar.size(); i++){
            cout << longestCar[i] << " ";
        }
        printf("%02d:%02d:%02d\n", maxTime / 3600, (maxTime % 3600) / 60, maxTime % 60);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值