原题描述:
Problem Description
The digital root of a positive integer is found by summing the digits of the integer. If the resulting value is a single digit then that digit is the digital root. If the resulting value contains two or more digits, those digits are summed and the process is repeated. This is continued as long as necessary to obtain a single digit.
For example, consider the positive integer 24. Adding the 2 and the 4 yields a value of 6. Since 6 is a single digit, 6 is the digital root of 24. Now consider the positive integer 39. Adding the 3 and the 9 yields 12. Since 12 is not a single digit, the process must be repeated. Adding the 1 and the 2 yeilds 3, a single digit and also the digital root of 39.
For example, consider the positive integer 24. Adding the 2 and the 4 yields a value of 6. Since 6 is a single digit, 6 is the digital root of 24. Now consider the positive integer 39. Adding the 3 and the 9 yields 12. Since 12 is not a single digit, the process must be repeated. Adding the 1 and the 2 yeilds 3, a single digit and also the digital root of 39.
Input
The input file will contain a list of positive integers, one per line. The end of the input will be indicated by an integer value of zero.
Output
For each integer in the input, output its digital root on a separate line of the output.
Sample Input
24 39 0
Sample Output
6 3
这道题可以说是很奇怪了。。。第一个想到的是用字符串记录输入的数字,这样方便计算各个位数上的值。。。但是一直加对10的余数不是也可以???
然鹅一直WA , 然后就一直WA !!! 最后测试了一个超级大的数999999999999(12个9),发现最后结果变成 -9 了惹!!! 好吧 其实原题并没给出这个数字的范围!!!无穷大怕也不是没有可能。。。坑的我啊!!!
#include <stdio.h>
int f( int d )
{
int b = 0 ;
for ( b = d%10 ; d >= 10 ; )
{
d /= 10 ;
b += d%10;
}
return b ;
}
int main ( )
{
int d ;
while ( ( scanf("%d",&d ) != EOF ) && d )
{
while ( f( d ) >= 10 )
{
d = f ( d ) ;
f ( d ) ;
}
printf("%d\n",f( d ) );
}
return 0;
}
字符串 (网上看到一个超简洁的代码)
#include<stdio.h>
int main()
{
int i,m;
char s[1000];
while(scanf("%s",s)==1&&s[0]!='0'){
for(m=i=0;s[i];i++)
m+=s[i]-'0';
printf("%d\n",m%9==0?9:m%9);
}
return 0;
}