N!Again

N!Again

Time Limit : 2000/1000ms (Java/Other) Memory Limit : 32768/32768K (Java/Other)
Total Submission(s) : 24 Accepted Submission(s) : 10
Problem Description
WhereIsHeroFrom: Zty, what are you doing ?
Zty: I want to calculate N!……
WhereIsHeroFrom: So easy! How big N is ?
Zty: 1 <=N <=1000000000000000000000000000000000000000000000…
WhereIsHeroFrom: Oh! You must be crazy! Are you Fa Shao?
Zty: No. I haven’s finished my saying. I just said I want to calculate N! mod 2009

Hint : 0! = 1, N! = N*(N-1)!

Input
Each line will contain one integer N(0 <= N<=10^9). Process to end of file.

Output
For each case, output N! mod 2009

Sample Input
4
5

Sample Output
24
120

2009=7*7*41,所以41的阶乘及其以后的数字对2009求模值为零,另外需要注意的是,n!%2009与1%2009*2%2009·····n%2009的值是一样的,所以不必在意多求了几次对2009的模,另外还要注意0%2009=1。

#include<stdio.h>
int main()
{
    int i,n,ji[41];
    while(scanf("%d",&n)!=EOF)
    {
        if(n>=41)
        {
            printf("0\n");
            continue;
        }
        ji[0]=1;
        ji[1]=1;
        ji[2]=2;
        if(n>=3&&n<41)
        {
            for(i=3;i<41;i++)
            ji[i]=(ji[i-1]*i)%2009;
        }
        printf("%d\n",ji[n]);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值