humble nunber

Problem Description
A number whose only prime factors are 2,3,5 or 7 is called a humble number. The sequence 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 12, 14, 15, 16, 18, 20, 21, 24, 25, 27, … shows the first 20 humble numbers.

Write a program to find and print the nth element in this sequence

Input
The input consists of one or more test cases. Each test case consists of one integer n with 1 <= n <= 5842. Input is terminated by a value of zero (0) for n.

Output
For each test case, print one line saying “The nth humble number is number.”. Depending on the value of n, the correct suffix “st”, “nd”, “rd”, or “th” for the ordinal number nth has to be used like it is shown in the sample output.

Sample Input
1
2
3
4
11
12
13
21
22
23
100
1000
5842
0

Sample Output
The 1st humble number is 1.
The 2nd humble number is 2.
The 3rd humble number is 3.
The 4th humble number is 4.
The 11th humble number is 12.
The 12th humble number is 14.
The 13th humble number is 15.
The 21st humble number is 28.
The 22nd humble number is 30.
The 23rd humble number is 32.
The 100th humble number is 450.
The 1000th humble number is 385875.
The 5842nd humble number is 2000000000.
题意:
如果应该是的因子只有2,3,5,7就称这个数为 humble nunber。
把这些 called a humble 从小到大组成一个数列;
输入一个数字n,输出这个数列中第n个数;
其中nth必须根据英语词法规范写;

思路:因为humble nunber的因子只有2,3,5,7;
所以后一个数可以由前一个数乘以2,3,5,7;

#include<bits/stdc++.h>
using namespace std;
long long min(long long a,long long b,long long c,long long d){
	long long aa,bb;
	aa=a<b?a:b;
	bb=c<d?c:d;
	if(aa<bb){
		return aa; 
	}
	else{
		return bb;
	}
}
int main(){
	long long s[6000];
	s[1]=1;
	long long p1=1,p2=1,p3=1,p4=1;
	int i=1;
	while(i<5842){
	i++; 
		s[i]=min(s[p1]*2,s[p2]*3,s[p3]*5,s[p4]*7);
		if (s[i]==s[p1]*2){
			p1++;
		}
		if (s[i]==s[p2]*3){
			p2++;
		}
		if(s[i]==s[p3]*5){
			p3++;
		}
		if(s[i]==s[p4]*7){
			p4++;
		}
	}
	int n;
	while(cin>>n){
		if(n==0){
			break;
		}
		else{
			if(n%10==1&&n%100!=11)
				printf("The %dst humble number is %lld.\n",n,s[n]);
			else if(n%10==2&&n%100!=12)
                printf("The %dnd humble number is %lld.\n",n,s[n]);
            else if(n%10==3&&n%100!=13)
                printf("The %drd humble number is %lld.\n",n,s[n]);
            else
                printf("The %dth humble number is %lld.\n",n,s[n]);
		}
	}
	return 0;
} 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值