ZOJ17th校赛I题Course Selection System

题目:
Course Selection System

Time Limit: 1 Second      Memory Limit: 65536 KB

There are n courses in the course selection system of Marjar University. The i-th course is described by two values: happiness Hi and credit Ci. If a student selects m courses x1, x2, ..., xm, then his comfort level of the semester can be defined as follows:

$$(\sum_{i=1}^{m} H_{x_i})^2-(\sum_{i=1}^{m} H_{x_i})\times(\sum_{i=1}^{m} C_{x_i})-(\sum_{i=1}^{m} C_{x_i})^2$$

Edward, a student in Marjar University, wants to select some courses (also he can select no courses, then his comfort level is 0) to maximize his comfort level. Can you help him?

Input

There are multiple test cases. The first line of input contains an integer T, indicating the number of test cases. For each test case:

The first line contains a integer n (1 ≤ n ≤ 500) -- the number of cources.

Each of the next n lines contains two integers Hi and Ci (1 ≤ Hi ≤ 10000, 1 ≤ Ci ≤ 100).

It is guaranteed that the sum of all n does not exceed 5000.

We kindly remind you that this problem contains large I/O file, so it's recommended to use a faster I/O method. For example, you can use scanf/printf instead of cin/cout in C++.

Output

For each case, you should output one integer denoting the maximum comfort.

Sample Input
2
3
10 1
5 1
2 10
2
1 10
2 10
Sample Output
191
0
Hint

For the first case, Edward should select the first and second courses.

For the second case, Edward should select no courses.

代码:

#include<stdio.h>
#include<stdlib.h>
#include<string.h>
#include<math.h>
# define MaxN 500+5
# define MaxC 500*100+5
typedef long long int LL;
LL max(LL a,LL b)
{
	return a>b ? a:b;
}
int main()
{
	
	int T;
	scanf("%d",&T);
	while(T--)
	{
		int dp[MaxC];
		int H[MaxN];
		int C[MaxN];
		memset(dp,0,sizeof dp);
		int N;
		int i;
		int TopC=0;
		scanf("%d",&N);
		for(i=1;i<=N;i++)
		{
			scanf("%d",&H[i]);
			scanf("%d",&C[i]);
			TopC+=C[i];
		} 
		for(i=1;i<=N;i++)
		{
			int l;
			for(l=TopC;l>=C[i];--l)		
					dp[l]=max(dp[l],dp[l-C[i]]+H[i]);
		}
		LL max1=0;
		for(i=0;i<=TopC;i++)
			max1=max(1LL*dp[i]*dp[i]-1LL*dp[i]*i-1LL*i*i,max1);
		printf("%lld",max1);
		if(T!=0)
			printf("\n");
	}
    return 0;
}
//这题是看了大牛的博客之后模仿写出来的,希望以后也能像大牛一样自己写出来吧

思路:

通过题目我们可以了解到在一定的C下H越高,comfort level就越高,所以我们应该求出在所有可能的C值下最高的H值,因为C的最大值并不大,题目给出不超过5000;因此我们可以创建一个数组来进行0/1背包的求解。求出每个C下最高的H,注意H的范围,所以int的范围是不够表达comfortable的值的,要用long long int,求出所有最高H后再进行计算,求出所有C中的最优解。

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值