ICPC2017网络赛(沈阳)1008&HDU6201transaction(spfa 费用流)

transaction transaction transaction

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 132768/132768 K (Java/Others)
Total Submission(s): 31    Accepted Submission(s): 15


Problem Description
Kelukin is a businessman. Every day, he travels around cities to do some business. On August 17th, in memory of a great man, citizens will read a book named "the Man Who Changed China". Of course, Kelukin wouldn't miss this chance to make money, but he doesn't have this book. So he has to choose two city to buy and sell.
As we know, the price of this book was different in each city. It is ai yuan in i t city. Kelukin will take taxi, whose price is 1 yuan per km and this fare cannot be ignored.
There are n1 roads connecting n cities. Kelukin can choose any city to start his travel. He want to know the maximum money he can get.
 

Input
The first line contains an integer T ( 1T10 ) , the number of test cases.
For each test case:
first line contains an integer n ( 2n100000 ) means the number of cities;
second line contains n numbers, the i th number means the prices in i th city; (1Price10000)
then follows n1 lines, each contains three numbers x , y and z which means there exists a road between x and y , the distance is z km (1z1000) .
 

Output
For each test case, output a single number in a line: the maximum money he can get.
 

Sample Input
  
  
1 4 10 40 15 30 1 2 30 1 3 2 3 4 10
 

Sample Output
  
  
8
 

Source
【题意】:

给出一个无向图,求从某一点到另一点的可以获得的最大利润。利润=汇点-路长-源点。

【解析】:

误打误撞,跑了n次spfa就过了。

【代码】:

#include <stdio.h>
#include <stdlib.h>  
#include <string.h>  
#include <iostream>  
#include <algorithm> 
#include <queue>  
#define mset(a,i) memset(a,i,sizeof(a))
using namespace std;
typedef long long ll;
struct node{
    int to,val,next;
}e[201010];
int n,m,x,y,val,cnt;
int head[100101];
ll dis[101001];
int a[120000];
void add(int x,int y,int v)
{
    e[cnt]=(node){ y,v,head[x] } ; 
    head[x]=cnt++;
}
void SPFA(int s)
{
    queue<int>Q;
    Q.push(s);
    while(!Q.empty())
     {
        int u=Q.front();
        Q.pop();
        for(int i=head[u];~i;i=e[i].next)
        {
            int v=e[i].to;
            if(dis[v]<dis[u]-a[u]+a[v]-e[i].val)
            {
                dis[v]=dis[u]-a[u]+a[v]-e[i].val;
                Q.push(v);
           }
        }
   }
}
int main() 
{
	int T;
	scanf("%d",&T);
	while(T--)
	{
		mset(head,-1);
		mset(dis,0);
		cnt=0;
		scanf("%d",&n) ;
		for(int i=1;i<=n;i++)
			scanf("%d",&a[i]);
	    for(int i=1;i<=n-1;i++)
	    {
	    	scanf("%d%d%d",&x,&y,&val);
			add(x,y,val);
	    	add(y,x,val);
		}
	    for(int i=1;i<=n;i++)
	    {
	  		SPFA(i);
		}
		ll ans=0;
		for(int i=1;i<=n;i++)
		{
			ans=max(ans,dis[i]);
		}
		printf("%lld\n",ans);
	}
    return 0 ;  
}


评论 4
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

雪的期许

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值