hdu1711 Number Sequence 求模式串在主串中的位置

Given two sequences of numbers : a[1], a[2], ...... , a[N], and b[1], b[2], ...... , b[M] (1 <= M <= 10000, 1 <= N <= 1000000). Your task is to find a number K which make a[K] = b[1], a[K + 1] = b[2], ...... , a[K + M - 1] = b[M]. If there are more than one K exist, output the smallest one.

Input
The first line of input is a number T which indicate the number of cases. Each case contains three lines. The first line is two numbers N and M (1 <= M <= 10000, 1 <= N <= 1000000). The second line contains N integers which indicate a[1], a[2], ...... , a[N]. The third line contains M integers which indicate b[1], b[2], ...... , b[M]. All integers are in the range of [-1000000, 1000000].

Output
For each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead.

Sample Input
   
   
2 13 5 1 2 1 2 3 1 2 3 1 3 2 1 2 1 2 3 1 3 13 5 1 2 1 2 3 1 2 3 1 3 2 1 2 1 2 3 2 1

Sample Output
   
   
6 -1

#include<iostream>
#include<cstring>
#include<cstdio>
#include<string>
using namespace std;
int s[1000010],t[10010];//s为主串,t为模式串
int nextx[10010];//从1开始
int slen,tlen;
void get_next()得到模式串str1的next[];
{
    int i=0,j=-1;
    nextx[0]=-1;
    while(i<tlen)
    {
        if(j==-1||t[i]==t[j])
            nextx[++i]=++j;
        else
            j=nextx[j];
    }
}
int kmp_index()返回首次出现的位置,从0开始
{
    int j=0;
    for(int i=0;i<slen;i++)
    {
       while(j!=-1&&s[i]!=t[j])
            j=nextx[j];
       j++;
       if(j==tlen)
           return i-tlen+2;
    }
    return -1;
}
int main()
{
    int T;
    cin>>T;
    while(T--)
    {
        cin>>slen>>tlen;
        for(int i=0;i<slen;i++)
            scanf("%d",&s[i]);
        for(int i=0;i<tlen;i++)
        scanf("%d",&t[i]);
        get_next();
        cout<<kmp_index()<<endl;
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值