POJ--1426.Find The Multiple(DFS)

该程序旨在找到一个非零的10进制数,该数仅由0和1组成并且是给定正整数n的倍数。通过深度优先搜索策略,从1开始递归地尝试在不超过100位数的情况下找到符合条件的数。代码中包含一个剪枝条件,即当位数达到19时停止,因为题目保证结果不会超过100位。对于每个输入的n,程序会输出一个对应的m值。虽然样例未能通过,但在实际提交时被接受,可能是因为其他解决方案在某些情况下也能得到正确答案。
摘要由CSDN通过智能技术生成

Find The Multiple

Time Limit: 1000MSMemory Limit: 10000K
Total Submissions: 72588Accepted: 28677Special Judge

Description

Given a positive integer n, write a program to find out a nonzero multiple m of n whose decimal representation contains only the digits 0 and 1. You may assume that n is not greater than 200 and there is a corresponding m containing no more than 100 decimal digits.

Input

The input file may contain multiple test cases. Each line contains a value of n (1 <= n <= 200). A line containing a zero terminates the input.

Output

For each value of n in the input print a line containing the corresponding value of m. The decimal representation of m must not contain more than 100 digits. If there are multiple solutions for a given value of n, any one of them is acceptable.

Sample Input

2
6
19
0

Sample Output

10
100100100100100100
111111111111111111

Source

Dhaka 2002

连样本数据都没过,但提交了就是对的,就离谱。看网上大神都是这么写的,思路是没错 

比较疑惑的是if(k==19)return;//剪枝  ,因为m最大可以到100位数,但是我们直接就取n<19位的....直接剪枝,咱也不知道为啥。

#include<string.h>
#include<iostream>
#include<stdio.h>
using namespace std;
typedef long long ll;
int n;
int f;

void dfs(ll x,int k)
{
	if(f)return;
	if(k==19)return;//剪枝
	if(x%n==0)
	{
		cout<<x<<endl;
		f=1;
		return;
	}
	
	
	dfs(x*10,k+1);
	dfs(x*10+1,k+1);
}

int main()
{
	
	while(cin>>n&&n)
	{
		f=0;
		dfs(1,0);//1开始,目前就1位数 
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值