Rightmost Digit

Rightmost Digit
Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u

Description

Given a positive integer N, you should output the most right digit of N^N. 
 

Input

The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow. 
Each test case contains a single positive integer N(1<=N<=1,000,000,000). 
 

Output

For each test case, you should output the rightmost digit of N^N. 
 

Sample Input

        
        
2 3 4
 

Sample Output

        
        
7 6

Hint

 In the first case, 3 * 3 * 3 = 27, so the rightmost digit is 7. In the second case, 4 * 4 * 4 * 4 = 256, so the rightmost digit is 6. 
         
 

快速幂的求法把要乘的这个数遍成((n)^2……)^2减少时间浪费
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
#include<cstdio>
int slove(int n,int m,int mod){//快速幂时间log2 N。
	int ans=1;
	int beas=n%mod;
	while(m){
		if(m%2==1){
			ans=(ans*beas)%mod;
		}
		beas=(beas*beas)%mod;
		m>>=1;
	}
	return ans;
}
int main(){
	int n,m,mod,T;
	scanf("%d",&T);
	while(T--){
		scanf("%d",&n);
		m=n;
		mod=10;
		printf("%d\n",slove(n,m,mod));
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值