HDU:1061 Rightmost Digit(规律)

Rightmost Digit

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 47557    Accepted Submission(s): 17968


Problem Description
Given a positive integer N, you should output the most right digit of N^N.
 

Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single positive integer N(1<=N<=1,000,000,000).
 

Output
For each test case, you should output the rightmost digit of N^N.
 

Sample Input
  
  
2 3 4
 

Sample Output
  
  
7 6
Hint
In the first case, 3 * 3 * 3 = 27, so the rightmost digit is 7. In the second case, 4 * 4 * 4 * 4 = 256, so the rightmost digit is 6.
 

Author
Ignatius.L
 

Recommend

题目大意:求n的n次方的个位数
解题思路:
列举下,能得规律,n的n次方的个位数跟它本身的个位数和十位数有关,要么是固定的,要么是循环的数字。

看代码就能看到规律了:
#include <stdio.h>
int main()
{
	int t;
	scanf("%d",&t);
	while(t--)
	{
		int n;
		scanf("%d",&n);
		int ge=n%10;//n的个位数 
		int shi=(n/10)%10; //n的十位数 
		if(ge==0)
		{
			printf("0\n"); 
		}
		if(ge==1)
		{
			printf("1\n"); 
		}
		if(ge==2)
		{
			if(shi%2==0)
			{
				printf("4\n");
			}
			else
			{
				printf("6\n");
			}
		}
		if(ge==3)
		{
			if(shi%2==0)
			{
				printf("7\n");
			}
			else
			{
				printf("3\n");
			}
		}
		if(ge==4)
		{
			printf("6\n"); 
		}
		if(ge==5)
		{
			printf("5\n"); 
		}
		if(ge==6)
		{
			printf("6\n"); 
		}
		if(ge==7)
		{
			if(shi%2==0)
			{
				printf("3\n");
			}
			else
			{
				printf("7\n");
			}
		}
		if(ge==8)
		{
			if(shi%2==0)
			{
				printf("6\n");
			}
			else
			{
				printf("4\n");
			}
		}
		if(ge==9)
		{
			printf("9\n"); 
		}
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值