杭电oj--1213 How Many Tables

Problem Description
Today is Ignatius' birthday. He invites a lot of friends. Now it's dinner time. Ignatius wants to know how many tables he needs at least. You have to notice that not all the friends know each other, and all the friends do not want to stay with strangers.

One important rule for this problem is that if I tell you A knows B, and B knows C, that means A, B, C know each other, so they can stay in one table.

For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C can stay in one table, and D, E have to stay in the other one. So Ignatius needs 2 tables at least.
 
Input
The input starts with an integer T(1<=T<=25) which indicate the number of test cases. Then T test cases follow. Each test case starts with two integers N and M(1<=N,M<=1000). N indicates the number of friends, the friends are marked from 1 to N. Then M lines follow. Each line consists of two integers A and B(A!=B), that means friend A and friend B know each other. There will be a blank line between two cases.
 
Output
For each test case, just output how many tables Ignatius needs at least. Do NOT print any blanks.
 
Sample Input
   
   
2 5 3 1 2 2 3 4 5 5 1 2 5
 
Sample Output
   
   
2 4
题目大意:第一行输入t,表示有t行测试实例,在输入n和m,表示有n各朋友,m对朋友。
  Ignatiu的朋友有一个原则:  他们是不会和陌生人在一个桌子上的。即 朋友的朋友是朋友,那么可以坐一个桌子上,问至少要有多少个桌子?

解题思路:并查集判断图连通,或者找出图有多少个连通分量

#include <iostream>
using namespace std;
#define N 1001
int father[N];
void init()//初始化并查集
{
	for(int i=0;i<N;i++)
		father[i]=i;
}
int getfather(int x)//获取父节点
{
	if(x != father[x])
		father[x] = getfather(father[x]); // 路径压缩修改的是father数组
	return father[x];
}
int main()
{
	int t,n,m,i,a,b;
	cin>>t;
	while(t--)
	{
		cin>>n>>m;
		init();
		while(m--)
		{
			cin>>a>>b;
			int cx=getfather(a);
			int cy=getfather(b);
			if(cx!=cy) {father[cx]=cy;}//合并两个元素所在的集合
		}
		int count=0;
		for(i=1;i<=n;i++)
		{
			if(father[i]==i)//扫描一遍father数组
			{	count++;}
		}
		cout<<count<<endl;
	}
	return 0;
}


  • 2
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值