POJ - 1860 Currency Exchange(最短路)

上题:

Several currency exchange points are working in our city. Let us suppose that each point specializes in two particular currencies and performs exchange operations only with these currencies. There can be several points specializing in the same pair of currencies. Each point has its own exchange rates, exchange rate of A to B is the quantity of B you get for 1A. Also each exchange point has some commission, the sum you have to pay for your exchange operation. Commission is always collected in source currency. 
For example, if you want to exchange 100 US Dollars into Russian Rubles at the exchange point, where the exchange rate is 29.75, and the commission is 0.39 you will get (100 - 0.39) * 29.75 = 2963.3975RUR. 
You surely know that there are N different currencies you can deal with in our city. Let us assign unique integer number from 1 to N to each currency. Then each exchange point can be described with 6 numbers: integer A and B - numbers of currencies it exchanges, and real R  AB, C  AB, R  BA and C  BA - exchange rates and commissions when exchanging A to B and B to A respectively. 
Nick has some money in currency S and wonders if he can somehow, after some exchange operations, increase his capital. Of course, he wants to have his money in currency S in the end. Help him to answer this difficult question. Nick must always have non-negative sum of money while making his operations. 
Input
The first line of the input contains four numbers: N - the number of currencies, M - the number of exchange points, S - the number of currency Nick has and V - the quantity of currency units he has. The following M lines contain 6 numbers each - the description of the corresponding exchange point - in specified above order. Numbers are separated by one or more spaces. 1<=S<=N<=100, 1<=M<=100, V is real number, 0<=V<=10  3
For each point exchange rates and commissions are real, given with at most two digits after the decimal point, 10  -2<=rate<=10  2, 0<=commission<=10  2
Let us call some sequence of the exchange operations simple if no exchange point is used more than once in this sequence. You may assume that ratio of the numeric values of the sums at the end and at the beginning of any simple sequence of the exchange operations will be less than 10  4
Output
If Nick can increase his wealth, output YES, in other case output NO to the output file.
Sample Input
3 2 1 20.0
1 2 1.00 1.00 1.00 1.00
2 3 1.10 1.00 1.10 1.00
Sample Output
YES
题意:
题的意思就是现在你有n个顶点和m条边,和你现在有的钱数,之后边是这样的 ,他给你1->2的的汇率和2->1的汇率 和他们之间的手续费,你兑换钱币的时候要减去汇率,问你是否存在一条路 ,使得兑换之后你的钱币比原来多,这道题 其实应该是要用 贝尔曼 或者spfa写的 ,然而当时写的时候这两种不是特别会写。。。而且看到顶点数并不是多少,于是就用floyd写了一发,当时写的时候比较麻烦的就是服务费的这个问题,服务费是要每兑换一次就要交一次钱的,思路就是 你先让所有的钱都赋0,然后你现有的钱种赋v,之后汇率和服务费分别存在两个数组中,这样我们得到的 最短路方程就是这样的 
(money[i]-cont[i][j])*map[i][j]>money[j],但想了想其实这样写 ,是不对的 ,,因为边其实松弛的次数是不够的 (?)
下面上代码 (以后会写贝尔曼和spfa)
#include<stdio.h>
float map[105][105]={0};
float cont[105][105]={0};
float money[103]={0};
int flag;
int n,m,s;
float v;
int floyd()
{
	float d[105];
	for(int i=1;i<=n;i++)
	{
		d[i]=money[i];
	}
	for(int k=1;k<=n;k++){
		for(int i=1;i<=n;i++)
		{
			for(int j=1;j<=n;j++)
			{
				if((money[i]-cont[i][j])*map[i][j]>money[j])
				{
					money[j]=(money[i]-cont[i][j])*map[i][j];
				}
			}
		}
	}
/*	for(int i=1;i<=n;i++)
	{
		printf("%f \n",money[i]);
	}*/
	for(int i=1;i<=n;i++)
	{
		if(d[i]<money[i])
		{
			return 1;
		}
	}
	return 0;
}
int main()
{
	
	
	while(scanf("%d%d%d%f",&n,&m,&s,&v)!=EOF)
	{
		int a,b;
		float c,d,e,f;
		flag=0;
		for(int i=1;i<=m;i++)
		{
			scanf("%d%d%f%f%f%f",&a,&b,&c,&d,&e,&f);
			map[a][b]=c;
			cont[a][b]=d;
			map[b][a]=e;
			cont[b][a]=f;
		}
		money[s]=v;
		floyd();//注释掉这个floyd就会worng。。。
		if(floyd())
		{
			printf("YES\n");
		}
		else 
		{
			printf("NO\n");
		}
	}
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值