HDU2923 Einbahnstrasse (最短路 floyd)

上题:
Einbahnstra e (German for a one-way street) is a street on which vehicles should only move in one direction. One reason for having one-way streets is to facilitate a smoother flow of traffic through crowded areas. This is useful in city centers, especially old cities like Cairo and Damascus. Careful planning guarantees that you can get to any location starting from any point. Nevertheless, drivers must carefully plan their route in order to avoid prolonging their trip due to one-way streets. Experienced drivers know that there are multiple paths to travel between any two locations. Not only that, there might be multiple roads between the same two locations. Knowing the shortest way between any two locations is a must! This is even more important when driving vehicles that are hard to maneuver (garbage trucks, towing trucks, etc.)

You just started a new job at a car-towing company. The company has a number of towing trucks parked at the company's garage. A tow-truck lifts the front or back wheels of a broken car in order to pull it straight back to the company's garage. You receive calls from various parts of the city about broken cars that need to be towed. The cars have to be towed in the same order as you receive the calls. Your job is to advise the tow-truck drivers regarding the shortest way in order to collect all broken cars back in to the company's garage. At the end of the day, you have to report to the management the total distance traveled by the trucks. Input
Your program will be tested on one or more test cases. The first line of each test case specifies three numbers (N , C , and R ) separated by one or more spaces. The city has N locations with distinct names, including the company's garage. C is the number of broken cars. R is the number of roads in the city. Note that 0 < N < 100 , 0<=C < 1000 , and R < 10000 . The second line is made of C + 1 words, the first being the location of the company's garage, and the rest being the locations of the broken cars. A location is a word made of 10 letters or less. Letter case is significant. After the second line, there will be exactly R lines, each describing a road. A road is described using one of these three formats:


A -v -> B
A <-v - B
A <-v -> B


A and B are names of two different locations, while v is a positive integer (not exceeding 1000) denoting the length of the road. The first format specifies a one-way street from location A to B , the second specifies a one-way street from B to A , while the last specifies a two-way street between them. A , ``the arrow", and B are separated by one or more spaces. The end of the test cases is specified with a line having three zeros (for N , C , and R .)

The test case in the example below is the same as the one in the figure.

Output
For each test case, print the total distance traveled using the following format:


k . V


Where k is test case number (starting at 1,) is a space, and V is the result.
Sample Input
4 2 5
NewTroy Midvale Metrodale
NewTroy   <-20-> Midvale
Midvale   --50-> Bakerline
NewTroy    <-5-- Bakerline
Metrodale <-30-> NewTroy
Metrodale  --5-> Bakerline
0 0 0
Sample Output
1. 80
大致题意就是 你现在有c辆小破车,你需要把它拉回来,然后又n个城市r条路,现在要你求出把这c辆小破车全部拉回来,所需要的最小的路程是多少(这破题要把我翻译死了 - -。。。 。),懂了题意之后就是非常简单的最短路问题,利用floyd 直接跑一边就好了,第一行的第一个就是起点,之后的c个地方就是你要到达的地方,这里floyd求完之后,求出起点到小破车所在的点的城市编号就好了,比较麻烦的是字符串的处理问题,最近自学了一下map  利用 map存一下就好了。想到这里大致问题就解决了!
现在上代码:
#include<stdio.h>
#include<string>
#include<string.h>
#include<map>
#define INF  999999999
using namespace std;
char dis[1000][1000];
int a[1000][1000]; 
map<string,int>mat;
int n,c,r,l;
void floyd()
{
	for(int k=1;k<=n;k++)
	{
		for(int i=1;i<=n;i++)
		{
			for(int j=1;j<=n;j++)
			{
				a[i][j]=min(a[i][k]+a[k][j],a[i][j]);
			}
		}
	}
}
int main()
{
	char  s1[1000],s2[1000];
	char a1,a2;
	int ca=0;
	while(scanf("%d%d%d",&n,&c,&r),n||c||r)//n表示的是 城市的数量,c的第一个表示的是公司所在的地点 接下来表示的是 车的地点 r表示的是路的地点 
	{
		mat.clear();  
		memset(s1,0,sizeof(s1));
		memset(s2,0,sizeof(s2));
		memset(a,0,sizeof(a));
		for(int i=0;i<=n;i++)
		{
			for(int j=0;j<=n;j++)
			{
				a[i][j]=INF;
			}
	//		a[i][i]=0;
		}
		for(int i=0;i<=c;i++)
		{
			scanf("%s",dis[i]);
		}
		int cnt=1;
		for(int i=0;i<r;i++)
		{
			scanf("%s %c-%d-%c %s",s1,&a1,&l,&a2,s2);
			if(!mat[s1])
			{
				mat[s1]=cnt++;
			}
			if(!mat[s2])
			{
				mat[s2]=cnt++;
			}
			int x=mat[s1],y=mat[s2];
			if(a1=='<')
			{
				if(a[y][x]>l)
				{
					a[y][x]=l;
				}
			}
			if(a2=='>')
			{
				if(a[x][y]>l)
				{
					a[x][y]=l;
				}
			 }	
		}
		int start=mat[dis[0]];
		int sum=0;
		floyd();
	/*	for(int i=1;i<=n;i++)
		{
			for(int j=1;j<=n;j++)
			{
				if(a[i][j]<INF)
				{
					printf("a[%d][%d]= %d  \n",i,j,a[i][j]);
				}
				`
				  
			}	
		}*/
		for(int i=1;i<=c;i++)
		{
		//	printf("dis[%d]=%d ",i,mat[dis[i]]);
			sum+=a[start][mat[dis[i]]]+a[mat[dis[i]]][start];
		}
		printf("%d. %d\n",++ca,sum);
	}
 } 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值